0

I just have done a fresh install of Raspbian Buster on a 3b+ on my home network. The box has been working fine for years running wheezy. The box isn't connected by ethernet.

Trying to set up Localisation prefs and the Wifi Country is greyed out and the Network icon on the top-right of desktop says no interfaces found.

Have tried setting the country name in raspi-config options but get an error saying N2 error.

Have tried:

nano /etc/wpa_supplicant/wpa_supplicant.conf

and edited to read:

   country=GB
_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid="<network_ssid>"
    psk="<network_password>"
}

but still can't find wifi networks or change Wifi country in preferences.

Does anyone help? Thanks

2
  • Does this answer your question? How do I set up networking/WiFi/static IP address?
    – Milliways
    Commented Mar 25, 2020 at 23:05
  • The box has been working fine for years running wheezy well, 2 years at most since that's how old that pi is - I find it amazing that two years ago you used wheezy, which is not supported on the 3B+ or even the 3B - in fact, not even jessie runs on the 3B+, stretch is the first version that supported the 3B+ Commented Mar 26, 2020 at 9:35

1 Answer 1

1

Configure the /etc/wpa_supplicant/wpa_supplicant.conf as the link below because it has not configured in a true way and some part of it has lost:

Setting WiFi up via the command line


My /etc/wpa_supplicant/wpa_supplicant.conf is like this and is working:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=IR

network={
     ssid="testssid"
     psk="tesspass"
}

Now, if you check the interface list by ifconfig you would not see the wlan0 on the list. So, you may found some solution that tells you to enable the wlan0 by ifconfig wlan0 up but it doesn't work and would give Operation not possible due to RF-kill as the output.


By the following procedure, it will be solved:

iwconfig wlan0 txpower off

sudo rfkill unblock all

Now you can bring it up:

ifconfig wlan0 up  

Check the wlan0 state by ifconfig, iwconfig or GUI on the top of the screen and you would see that it has worked.


References:

15
  • Hi, thanks for replying. When I type ifconfig wlan0 up I get the message wlan0: ERROR while getting interface flags: No such device. So I continue and type iwconfig wlan0 txpower off and get the message Error for wireless request "Set Tx Power (8B26) : SET failed on device wlan0 ; Operation not permitted Commented Mar 25, 2020 at 16:06
  • forgot to say, i edited my wpa_supplicant to look like yours except for country=GB Commented Mar 25, 2020 at 16:13
  • @M.Rostami Have in mind that the OP is still using Wheezy, e.g. rfkill isn't needed and maybe other things are different?
    – Ingo
    Commented Mar 25, 2020 at 16:22
  • I'm using a fresh install of buster. Just tried those commands prefixed by sudo and got exactly the same error messages. Commented Mar 25, 2020 at 16:23
  • @user1106252 You should add this important information to your question. Please edit it.
    – Ingo
    Commented Mar 25, 2020 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.