2

I want to install OpenVPN Server on my Raspberry Pi 2, following the same steps I used in a virtual machine running Ubuntu 19.10
Ubuntu works fine, but Raspberry goes on error during the installation of TUN driver.

Here are my steps:
- install TUN driver with this script. I had to add on Raspberry Pi:

sudo apt install raspberrypi-kernel-headers

It seems to work, but if I list the interfaces with:

ifconfig

I don't see the tun0 interface, while on Ubuntu I see it. reboot didn't solve it.


Here are some details:

  • Raspberry Pi 2 model B
  • Raspbian Buster (release date 2020-02-13, Kernel version: 4.19)

Anyone can help me?
Thanks!

5
  • sudo ip tuntap add dev tun0 mode tun – Dougie Mar 26 '20 at 18:28
  • The tun module is available w/ the stock kernel. – goldilocks Mar 26 '20 at 20:58
  • @goldilocks - no deprecation message that I can see – Jaromanda X Mar 26 '20 at 21:59
  • Please delete your duplicate question on Stack Overflow. – Rob Mar 27 '20 at 12:41
  • @JaromandaX Oh yeah! Debian does not have that; wikipedia notes "many Linux distributions have deprecated...", not all. My bad, thanks. – goldilocks Mar 27 '20 at 13:43
2

Though not a direct answer the PiVPN Project here has installed fine on slightly older models before.

If you link was actually to enter link description here then be aware that is for a six year old version of Ubuntu and not the latest version of Debian.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.