4

I installed OMV 5 in my Raspberry Pi 4B running Raspbian GNU/Linux 10 (buster), following this video https://www.youtube.com/watch?v=sYDyvr9Uc6Y (script installation).

Just right after install OMV 5 and reboot the RPi 4B the WiFi stopped working. As can be seen in the picture 1 the WiFi complains about that there's "No wireless interface found".

enter image description here

Well, I've checked my /etc/wpa_supplicant/wpa_supplicant.config, which contains:

pi@raspberrypi:~ $ cat /etc/wpa_supplicant/wpa_supplicant.conf 
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=ES

network={
        ssid="mywifi1"
        psk="psswd"
        key_mgmt=WPA-PSK
}

network={
        ssid="mywifi2"
        psk="passwd"
        key_mgmt=WPA-PSK
}

which looks correcto to me, and what I have before installing OMV 5. One thing that have changed is the /etc/network/interface file. It now looks like:

pi@raspberrypi:~ $ cat /etc/network/interfaces
# This file is auto-generated by openmediavault (https://www.openmediavault.org)
# WARNING: Do not edit this file, your changes will get lost.
# Use systemd-networkd to configure additional interface stanzas.

when it used to contain:

pi@raspberrypi:~ $ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

I've tried to raplace it with the original file but still doesn't work. I've downloaded a fresh Raspbian 10 image to check the differences between these files and everything looks the same except for this /etc/network/interface file. I've also checked the content of /etc/dhcp/ and is the same as the fresh Raspbian version.

Further, when I trie to use raspi-conf to change things in the wpa_supplicant is complains as follows: enter image description here enter image description here enter image description here enter image description here

I've also done a rpi-update to update the firmware. I've heard that OMV might disable or remove wifi drivers but when I do

pi@raspberrypi:~ $ sudo lshw -C network
*-network:0               
     description: Ethernet interface
     physical id: 1
     logical name: eth0
     serial: dc:a6:32:60:6c:b2
     size: 1Gbit/s
     capacity: 1Gbit/s
     capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
     configuration: autonegotiation=on broadcast=yes driver=bcmgenet driverversion=v2.0 duplex=full ip=192.168.0.13 link=yes multicast=yes port=MII speed=1Gbit/s
*-network:1 
     description: Wireless interface
     physical id: 2
     logical name: wlan0
     serial: dc:a6:32:60:6c:b4
     capabilities: ethernet physical wireless
     configuration: broadcast=yes driver=brcmfmac driverversion=7.45.202 firmware=01-72f6ece2 multicast=yes wireless=IEEE 802.11

Does anyonw know how to fix it? Any help?

5
  • Please don't post pictures of text. Instead paste the thext direct into the question.
    – Ingo
    Commented Mar 30, 2020 at 11:51
  • @Ingo Ok, sorry. I thought it would be more easy to understand. Should I change it?
    – ILA
    Commented Mar 31, 2020 at 8:56
  • Ok. I found a temporary solution. What I see is that wlan0 interface is down. To set it up I see you can do sudo ip link set wlan0 up and then sudo wpa_supplicant -B -D wext -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf But this fixes the problem for a while. After reboot everything is down again.
    – ILA
    Commented Mar 31, 2020 at 8:59
  • "Should I change it?" - next time :)
    – Ingo
    Commented Mar 31, 2020 at 9:10
  • I dont know why I cannot post anwers, but I solved this via "omv-firstaid" Commented Feb 9, 2022 at 19:48

7 Answers 7

4

I had the exact same issue after installing OMV 6 on a fresh install of Raspberyy Pi Lite (64-bit) OS, and I fixed it using omv-firstaid.

Here are the steps:

  1. Connect to your Raspberry Pi using an ethernet cable or directly using a keyboard and monitor.
  2. Run sudo omv-firstaid
  3. Select Configure Network Interface (it is the first option in my case)
  4. Select wlan0 (or your wireless interface), and follow the prompts including selecting your wireless network SSID and password.

It would be stuck at "Configuring network interface. Please wait ..." for several minutes, but finally should reboot automatically. After reboot, the Wifi should work again.

1

Try adding id_str to the network definition:

network={
        ssid="mywifi1"
        psk="psswd"
        key_mgmt=WPA-PSK
    id_str = "wlan1"

}

network={
        ssid="mywifi2"
        psk="passwd"
        key_mgmt=WPA-PSK
    id_str = "wlan2"

}
1

It seems OMV completely occupies the network setup with its own settings and destroy the default Raspbian networking with dhcpcd. OMV modifies /etc/network/interfaces and claims to use systemd-networkd for network setups. Both systems are not used by Raspbian so I'm afraid you are without luck to use OMV with Raspbian if you do not find instructions from OMV how to configure the network to be compatible with Raspbian. B.t.w., using rpi-update will make things rather bad.

1
  • Yes, this is what it looks like. But I don't see the point, in case you cannot use (don't want to) Ethernet connection, as in my case, you cannot access your server via WiFi... Thanks for the answer, I'll as in OMV forum if they ever know how to fix it. However, I managed to make it work for a while using this WiFi set-up guide [linuxcommando.blogspot.com/2013/10/…. But after reboot the configuration is not saved.
    – ILA
    Commented Mar 31, 2020 at 8:37
1

This worked for me.

This will make it activate and visible in the ifconfig

ifconfig wlan0 up

This will allow pi to get the ipaddress

sudo dhclient -4 wlan0

P.S. Make sure your wlan0 is your WiFi adapter you are trying to connect to internet.

0

Under Buster, you will need to set in raspi-config under

4 Localisation Options

the Wifi country

I4 Change Wi-fi Country

otherwise, the Wifi will be disabled by rfkill.

5
  • What does these lines mean? Where to set them?
    – Ingo
    Commented Mar 30, 2020 at 11:35
  • You may have recognized the 4 Localisation Options form the first menu that the OP posted. Commented Mar 31, 2020 at 8:14
  • Thanks for the answer @LjmDullaart. I've seen this "Set Country" in many places but I don't understand why the country is so importat. Could you explain? Further, as in the explample I put in my post trying to set the SSID via raspi-config, when trying to set the country it says the same that `Could not communicate with wpa_supplicant
    – ILA
    Commented Mar 31, 2020 at 8:52
  • Different countries have different laws for frequency assignments and allowed power. But for some reason, from Raspian Buster on, it has been decided to kill any WiFi until the country is set via the menu, via the localisation options. Set the coutry before you define the SSID. I don't know why that suddenly got so important, so I can't explain it. I just know that I spend hours trying to get WiFi going on buster, and this was the solution. Commented Mar 31, 2020 at 10:29
  • I see. Thanks for the info. I've seen this in many places so I guess Rapsbian Buster does what you say and requires to set the country via raspi-config.
    – ILA
    Commented Mar 31, 2020 at 11:11
0

This guide describes one approach that saved me from having to reformat my RaspberryPi and got me back:
• internet connection
• functional OpenMediaVault

The following instructions are
• assuming your network is based on the eth0
• assuming that your WiFi/Router is on 192.168.3.1
• assuming that your static IP address is 192.168.3.41
• assuming you are familiar with the acronym OMV which means Open Media Vault

This is a temporarily fix for the network connection. It's temporary because if you reboot you will lose the connectivity till we get back the permanent solution which is described below.

Edit and save the following lines in your /etc/dhcpcd.conf to enable DHCP and get back the network working.

interface eth1
static ip_address=192.168.3.41/24
static routers=192.168.1.1 
static domain_name_servers=1.1.1.1

Note: 1.1.1.1 is CloudFlare's DNS, more on this here. You can use a different one if you like.

Now run sudo ifdown eth0 && sudo ifup eth0 to restart the eth0 network interface.

At this point your network should be working.

Now let's try to fix OMV by:

Uninstalling OMV apt-get remove --autoremove openmediavault

Re-Installing OMV wget -O - https://raw.githubusercontent.com/OpenMediaVault-Plugin-Developers/installScript/master/install | sudo bash

Tip: To configure later the Open Media Vault you can use this guide)Failed to connect to socket: No such file or directory

Note: Initially the installation for myself failed because OMV was pointing to an interface different to eth0 and it couldn't detect the MAC address. If you see such error, then manually edit the file and set your interface for eth0 and provide its MAC address. To get the MAC address of your interface you can list it by running ifconfig

At this point the installation should be completed.
Run sudo omv-firstaid and select the following from the menu list so you can let OMV to automatically setup the DHCP.

Select 1 Configure network interface
Select as network interface eth0 Do you want to configure IPv4 for this interface? Yes
Do you want to use DHCPv4 for this interface? Yes
Do you want to configure IPv6 for this interface? No
Do you want to enable WOL for this interface? No

The process is going to take a few minutes, you will see the message:
Configuring network interface. Please wait...

...wait patiently till you see the message:
The network interface configuration was successfully changed.

If the above fails with an error with message Failed to connect to socket: No such file or directory or related to /var/lib/openmediavault/engined.sock then based on this your main OMV engine is not running.

In this case, open a new terminal and run sudo omv-engined -d -f

then leave the terminal window open - do not close it - then re-run sudo omv-firstaid on your other terminal and go through the options described above.

If after rebooting you can't login to the OMV through the WebUI can use the omv-firstaid to reset your admin password

If after rebooting, you've noticed that even though you have reset your admin password you still can't access OMV due to Failed to connect to socket: Connection refused then you can try this to get your omv-engined re-starting and running properly after reboots.

0

I logged in as admin while connected to LAN,opened the UI http://ipaddress/#/network/interfaces, in upper left there was a + and I added back my wlan there, put in the SSID and password. Hit apply check mark and it works now.

2
  • Open Media Valut isn't an GUI app.
    – MatsK
    Commented Oct 30, 2023 at 10:04
  • Open Media Valut isn't an GUI app.
    – MatsK
    Commented Oct 30, 2023 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.