I have a Raspberry Pi running Debian. The boot.rc file in the boot partition is replaced with the boot_enable_ssh.rc so that I can access it with ssh. After that did not work, I connected it to a screen and watched the output. The boot process seems to be caught in a loop, it always comes to the "Raspberry Pi rebooting..." output, then some more and then it reboots.

I took two photos of the screen output, I hope it is possible to read and contains enough information: enter image description here enter image description here

After the last line in the second picture ("will now restart.") it reboots and comes to the same point. Can someone identify the problem? I noticed that the first mention of rebooting comes directly after the ssh server is loaded.


On a different SD-card but with the same power supply I tried Arch Linux and it worked, so I do not think that the power supply is the problem.

  • My first guess is a bad SD Card or image. Do you have another to test with. How are you powering your Pi? Commented Jul 16, 2012 at 20:25
  • 2
    Maybe some joker has written init 6 in that ssh script ;-)
    – Jivings
    Commented Jul 16, 2012 at 20:44
  • I power it with my mobile charger. That works with Arch Linux, so I think power supply is fine.
    – Till B
    Commented Jul 17, 2012 at 7:25
  • Does Debian work with boot.rc rather than boot_enable_ssh.rc? Commented Jul 17, 2012 at 7:31
  • Is this Debian squeeze or wheezy? - You may want to upgrading to wheezy - has a lot of fixes and it has SSH turned on by default. See here: raspberrypi.org/archives/1435 Commented Jul 17, 2012 at 9:13

6 Answers 6


I have a similar problem. My Raspberry Pi also keeps rebooting. After reading the following page, I measured the voltage on the board between TP1 and TP2, and I discovered that at boot time the voltage was fluctuating a lot.


I am using a powered USB hub to power the Raspberry Pi. On the USB connectors, I measured 5.2 Volts and 1.25 amps, which should be sufficient. However, at the other end of the 8 foot USB to Micro-USB cable I am using, I measured 5.2 Volts and 0.6 Amps, which is not enough for the Raspberry Pi. So there seems to be a lot of attenuation in the cable. I then tried a 4 foot cable, but I am still having the same reboot problem. I am not able to measure the current at the end of this cable however. My multimeter wires are too thick to reach the tiny connectors.

So I don't know what to do. I could buy yet another cable, but will this one work?

You may be having the same problem. If you have a multimeter, follow the procedure on the page above to see whether the Pi receives sufficient power.

  • How are you measuring current at the end of the cable? Unless you have rigged up something where you insert your meter in the VBUS line, you are measuring incorrectly and producing results of dubious relevance. Though obviously, not using an 8 foot cable is a worthwhile experiment. Commented Aug 3, 2012 at 1:16
  • Sounds like a good advice, thank you. I will measure that with my Rpi. However I think that it was not the cause, my power supply is quite strong.
    – Till B
    Commented Aug 3, 2012 at 7:53
  • 1
    @ChrisStratton I don't know what a VBUS line is. I simply taped a needle onto my multimeter red lead. I then measured the current between the micro-USB connector ground and the +5 V pin. With the needle attached to the lead, I was able to reach the pin. Commented Aug 5, 2012 at 22:42
  • I bought another cable and it was still not good enough. The I realized that my Kindle cable is a USB cable with a micro-USB connector at one end. I tried it and it worked. I now have over 4.7 Volts between TP1 and TP2 with this cable. Commented Aug 5, 2012 at 22:44
  • @Jean-FrançoisBeauchamp sounds like your current test was to short out the power supply with an ammeter, which is generally not a test you want to do. It's meaningless (since the voltage at short-circuit current won't run anything), stresses the current protection components, and if they are absent risks blowing the fuse in your meter (or your meter itself if that is absent). Commented Aug 5, 2012 at 22:52

Try using a different power cable and adapter. Maybe the adapter and/or power cable may have been damaged and it may not be providing enough power to support Debian


You can plug the SD card into a PC and look at that file. While it's in the PC, you can also rename the file back to see if it stops the rebooting.

If you can get it to reboot without ssh running, the next thing to try would be starting ssh manually.

I would check that the power supply is ok. A weak power supply could cause things like that.

Next try a different SD card. Maybe even a different brand.

If all that fails, maybe you have a Lemon Pi :(

  • The same power supply with Arch works. I will try what you suggested.
    – Till B
    Commented Jul 17, 2012 at 7:26
  • @TillB, If the supply were marginal it's possible it could survive the Arch startup, but maybe the Debian uses more power at some stage. Dunno how likely it is though. I have been able to run fine just from a USB port on a laptop so far, but I have not been taxing the cpu or the gpu yet. Commented Jul 17, 2012 at 7:46
  • it supplies 0.7 Amps.
    – Till B
    Commented Jul 17, 2012 at 7:52

It was the CABLE! Several of them.


I ran across this:

sudo iwconfig wlan0 power off

It's explained here:

About deauthenticating from * by local choice (reason=3) – xAppSoftware


I had this problem with my RP 3b. What fixed it was to switch to a power supply which gave more electric current (Amperes), and also a different USB cord. The old power supply gave 2 Amps, and the new one 2.4. So I think trying with a better power supply and also different cords can fix the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.