0

I'm sorry if this question has already been asked but I've been looking for a while and I can't find anything that's really helped.

I recently got a Raspberry Pi 4b but when I connect it to a screen, green and red lights flash initially and I start to see it boot up but (with a one time exception) it crashes before it has finished booting and the green light stops flashing. Before it crashes it shows a rainbow screen then shows 4 of the raspberry pi symbols in the top left and sometimes starts to have the text below it before it crashes. When I boot it without an SSD, the red light is on and the green light flashes 4 times on a loop. I've tried everything I can find but this seems to be buried under the SPI EEPROM problem and I can't seem to find anyone else who has quite the same problem.

Any advice would be greatly appreciated.

EDIT: I have since tried it with the official raspberry pi power supply and still have the same issue. I have also read through the pi4b post in the sticky and none of those issues seem to be the case (I do get the 4 flashes with no ssd so it's not the EEPROM issue, I have been using blank versions or raspbian on both a 16GB and a 32GB ssd, The green light gradually stops flashing and does not flash regularly, I only have the power and microHDMI plugged in (I've tried 2 separate cords for both)).

  • Try creating a new SDCard with plain Raspbian or plain Raspbian Lite and booting that. If it boots run sudo apt update; sudo apt dist-upgrade -y; sudo reboot to pull in the latest fixes and latest EEPROM code. The go back to the original SDCard and see if you can work out why it doesn't boot normally. – Dougie Mar 31 at 20:24
  • I can try the upgrade if it boots again but I've just been trying to boot it for the first time so the software is all plain. – wmcd0298 Apr 1 at 4:09
  • Please have a look at The Boot Problems Sticky. – Ingo Apr 1 at 10:10
0

The most common issue with the Pi 4 and booting is an inadequate power supply. What PS are you using and what is its output capacity.

The best results are with a genuine Raspberry Pi 4 supply with the USB-C output. Most other supplies do not provide enough output current to make the 4 work properly.

| improve this answer | |
  • I'm using a SABRENT fast charging usb hub that claims to output 5V and 3A max. I also ordered a genuine supply but it hasn't arrived yet and I've not got high hopes on reliable shipping any time soon and based on the specs of this it SHOULD work right? – wmcd0298 Apr 1 at 4:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.