0

I can't install the library 'digi-xbee' to my python 2.7. When i run this command pip install digi-xbee, i had this error: No matching distribution found for digi-xbee

Could you help me for fixing this error ?

3
  • Python2 isn't supported anymore. You should use Python3. – Ingo Apr 1 '20 at 10:21
  • Well, how can i check if python 3 is installed or not ? – Elhoo Eltou Apr 1 '20 at 13:54
  • Call python3 --help – Ingo Apr 1 '20 at 16:32
1

Looking at the PyPi repo it's only available for Python 3

https://pypi.org/project/digi-xbee/

2
  • i installed python3 but the error "No matching distribution found for digi-xbee" persists.What must i do ? – Elhoo Eltou Apr 6 '20 at 9:05
  • For python 3 you need to use pip3 instead of pip – Dirk Apr 6 '20 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.