0

I'm connected to my RPi4 using ethernet and ssh from my laptop. I'm able to ping github.com and receive packets. The error I get when trying to clone a repo is:

fatal: unable to access 'https://github.com/aws/aws-iot-device-sdk-js.git/': Failed to connect to github.com port 443: No route to host

I've also enable SPI in the interfacing options since last time that seemed to fix a similar error I was getting.

Thanks for any ideas.

3
  • Can you open a web browser and point to github.com on the Pi to identify whether SSH properly works?
    – PMF
    Apr 2, 2020 at 6:04
  • 1
    Post the exact command which gives you the error. Chances are, you made a typo in it. Apr 2, 2020 at 7:30
  • "using ethernet and ssh from my laptop" (I assume this means "I plugged in the Pi to my laptop directly using ethernet) combined with "no route to host" means that laptop isn't routing connections from your pi to the internet. Did you set up some kind of internet connection sharing on your laptop?
    – msanford
    Mar 26, 2021 at 1:55

1 Answer 1

0

I am having the same problem connecting to various website while using the Pi on WiFi. I connected an ethernet cable to the pi and suddenly everything works again. There must be a problem in the way one of the recent updates has configured the WiFi settings. It looks like the IPv4 is disabled while the IPv6 continues to function normally. With the ethernet cable connected, the IPv4 is resolved on the hard-line connection and things started working again.

1
  • This is likely specific to your router configuration and unlikely to help others. I get an IPv4 address on my Pi over WiFi. Also, there is no reason apt should not work with IPv6. Mar 31, 2021 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.