I am trying to access a new PI Zero W headless on Windows 10. I have followed the instruction at: https://desertbot.io/blog/headless-pi-zero-w-wifi-setup-windows

I get the putty window open that asked for "login as:" and I put pi. That causes a putty fatal error: No supported authentication methods available (server sent: publickey)

I have found several descriptions of how to fix this problem but all either assume that I have access to the Zero with a monitor and keyboard or assume that I am running a linux operating system.

What is causing the problem and is there a way to fix it using only Windows 10.

  • By default SSH on the RPF Raspbian images can be accessed with a password. Are you sure you're trying to connect to the correct computer? – Dirk Apr 3 at 20:34
  • Yes! I followed the process described in the link above for a clean install. One comment I found on web was that putty may get confused if you accessed other Pi's. I have accessed a Pi3 and Pi4 with no problem. Just the Zero headless. – GuyB Apr 3 at 21:18
  • BTW: Never was asked for password. As soon as you type pi for login putty terminates. – GuyB Apr 3 at 21:19
  • You could try running putty -cleanup BUT BE AWARE this will DELETE ANY and ALL keys and settings you have created for PuTTY – Andyroo Apr 4 at 15:53
  • Tried the putty -cleanup. That didn't solve the problem. Could Windows 10 be blocking access? Where to look? – GuyB Apr 4 at 18:07

I found a work around "error: No supported authentication methods available (server sent: publickey)". Using "yourhostname.local" for the houstname in putty did not work. I spent the day locating the access to my router. Once there I could see the IP address for the headless Pi Zero.

Burned a copy of Buster and brought it up on a Pi 4 with a monitor. Set the WIFI and accessed the Pi 4 on putty through WIFI. Now that I have a working WIFI I moved the SD to the PI Zero and looked up the assigned IP on the router. ALL Good.

| improve this answer | |
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Apr 9 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.