1

TL:DR: Previously working setup now fails with no apparent hardware damage, nor deliberate software changes.

My original setup had been working without problem since Sep 2019.

I powered it down, dismantled it to move to better location, re-assembled, powered up and….

...ICY DOCK 2-bay SATA <> USB3 device not recognised.

The working configuration was:

Raspberry Pi 4b (4GB) in FLIRC case, Raspberry Pi 4 4GB RAM, Official Raspberry Pi USB C PSU. USB3 > IcyBox IB-120CL-U3

Seagate Ironwolf 8TB Seagate Ironwolf 4TB

USB3 > Tooploo

Seagate 3TB WD 3TB

Gbit Ethernet

Openmediavault 4.1.35-1 Arrakis

As far as I can determine with the resources I have just now, the Pi4 hardware is working, the attached HDDs are all working but the HDDs connected via a previously working ICY DOCK 2-bay USB3 device are not recognised. Looks like the ICY DOCK connection is involved in the problem.

After MUCH!! Diagnosis, I’m no closer to finding a culprit.

Is there a possibility that some software / firmware component has been changed which prevents the system connecting via the USB3 ports to an ICY DOCK 2-Bay USB3?

I have 2 (two) identical ICY DOCK 2-bay devices, one of which has been happily connected to USB2 on my Synology NAS for ages, the other connected to the Pi4 USB3 since Sep 2019..

I have: Swapped ICY DOCKs Swapped USB3 cables Swapped Power supplies 12v 3A)

After failure, I have established:

All HDDs are readable in various other devices

Generally, either ICY DOCK with single HD works on USB2 port of Pi, but are not seen on USB3 ports.

An old USB2 Dock / Seagate 3TB connected to USB3 port on Pi works.

A “Tooploo” USB3 2-bay Dock with any single or any pair of HDDs connected to USB3 on Pi works.

My conclusions to date:

USB3 ports on Pi are WORKING ALL HDDs are WORKING USB3 cables on USB2 port WORKING ICY DOCKs USB2 WORKING on USB2 ports ICY DOCKs USB2 NOT WORKING on USB3 ports

I do not have any other device which I can test USB3 connection from ICY DOCK I have another USB3 cable on order.

I can imagine that ONE ICY DOCK and/or USB3 cable has failed in a way that USB2 works and USB3 doesn’t, but I struggle to believe BOTH sets have failed the same way.

I have outputs from lsusb -v from before and after connecting the ICY DOCK, and the only difference is:

Not connected; . . . Hub Port Status: Port 1: 0000.02a0 5Gbps power Rx.Detect

Connected: . . . Hub Port Status: Port 1: 0000.0263 5Gbps power suspend enable connect

Any ideas???

5
  • Gut feel is the controller is not responding - If you just run lsusb does it detect the device as a USB to SATA at all?
    – user115418
    Apr 4 '20 at 18:32
  • I have just moved the IcyDock to USB2 port and re-connected the Tooploo to the USB3 port. The two disks in the Tooploo are correctly recognised and mounted. The HDD in the IcyDock is not seen on USB2.
    – WSMWN4
    Apr 5 '20 at 0:18
  • Here's an lsusb: $ lsusb Bus 002 Device 002: ID 152d:0561 JMicron Technology Corp. / JMicron USA Technology Corp. JMS551 - Sharkoon SATA QuickPort Duo Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 005: ID 067b:2773 Prolific Technology, Inc. PL2773 SATAII bridge controller Bus 001 Device 004: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader Bus 001 Device 003: ID 1a40:0101 Terminus Technology Inc. Hub Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub $
    – WSMWN4
    Apr 5 '20 at 0:26
  • I don't understand how the "Sharkoon" entry gets there - and I'm sorry about the formatting of my reply - I haven't got the hang of this forum yet :( Do I really have to format all my reply in HTML??? Also when I say the IcyDock is not seen, I mean by the OMV GUI - I haven't yet tried to look for it via terminal.
    – WSMWN4
    Apr 5 '20 at 0:30
  • Update / resolution on my problem: New installation of Openmediavault v5. Tried numerous configurations of Docks / disks until I noticed that the ICYDock would sometimes work - on USB3 - with a WD3TB HDD. I then realised it worked consistently with any drive if I pressed the “Reset” button on the ICYDock after loading the drive. Adding a second drive needed another press of the reset - - - and - - - ALL IS GOOD. I still have no idea how the whole thing worked when I originally set it up - maybe I was just lucky in the sequence of adding devices and drives?? Thanks to all who responded!
    – WSMWN4
    Apr 11 '20 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.