0

I recently did apt-get update + apt-get dist-upgrade and after reboot my DS18B20 stopped working.

ls /sys/bus/w1/devices/ results in:

 w1_bus_master1

But previously I had dirs for my two sensors there.

In dmesg I noticed that there is an error message:

gpio-4 (onewire@0): enforced open drain please flag it properly in DT/ACPI DSDT/board file

I don't know if it is related as I don't know if it was pre-upgrade.

I have Raspberry Pi 4 (first version) and kernel 4.19.97-v7l+.

My sensors are correctly connected to GPIO 4, there is a pull-up resistor, and the whole config was working perfectly for 4 years (previously on Rpi 3 and even more previously on Rpi 1).

3
  • I suggest you revert the software to an earlier version.
    – joan
    Apr 4, 2020 at 15:14
  • @joan How should I do that? I suspect the kernel is the issue, but I don't know what version I had previously (I don't remember when I did upgrade last time). Apr 4, 2020 at 15:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.