0

after upgrading to debian 10, have encountered problems with the sound transmitted to my bluetooth headphones. The pairing between the RPI and the headphones is done, once from the audio menu I choose the headphones I hear the beep that they are hooked But the sound is not there and always remains on analog or HDMI. With pulseaudio it does not even find the headphones from the audio output menu.

This is the status of bt:

pi@raspberrypi:~ $ sudo systemctl status blue*
● bluealsa.service - BluezALSA proxy
   Loaded: loaded (/lib/systemd/system/bluealsa.service; static; vendor preset: 
   Active: active (running) since Sat 2020-04-04 18:46:32 CEST; 39min ago
 Main PID: 857 (bluealsa)
    Tasks: 5 (limit: 2200)
   Memory: 1.2M
   CGroup: /system.slice/bluealsa.service
           └─857 /usr/bin/bluealsa

apr 04 18:46:48 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 18:46:48 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 18:46:48 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 18:46:48 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 19:25:04 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 19:25:04 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 19:25:04 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 19:25:04 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 19:25:04 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes
apr 04 19:25:04 raspberrypi bluealsa[857]: /usr/bin/bluealsa: Unsupported AT mes

● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset
   Active: active (running) since Sat 2020-04-04 18:46:32 CEST; 39min ago
     Docs: man:bluetoothd(8)
 Main PID: 853 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 2200)
   Memory: 2.3M
   CGroup: /system.slice/bluetooth.service
           └─853 /usr/lib/bluetooth/bluetoothd

apr 04 18:46:32 raspberrypi bluetoothd[853]: Endpoint registered: sender=:1.19 p
apr 04 18:46:32 raspberrypi bluetoothd[853]: Endpoint registered: sender=:1.19 p
apr 04 18:46:32 raspberrypi bluetoothd[853]: Failed to set privacy: Rejected (0x
apr 04 18:46:48 raspberrypi bluetoothd[853]: Endpoint registered: sender=:1.19 p
apr 04 18:46:48 raspberrypi bluetoothd[853]: sdp_process: Protocol error: wrong 
apr 04 18:46:48 raspberrypi bluetoothd[853]: D8:AF:F1:6D:4D:E9: error updating s
apr 04 18:46:48 raspberrypi bluetoothd[853]: Browsing: connect error: Connection
apr 04 18:52:07 raspberrypi bluetoothd[853]: Unable to get io data for Hands-Fre
apr 04 18:52:28 raspberrypi bluetoothd[853]: Unable to get io data for Headset V
apr 04 19:25:10 raspberrypi bluetoothd[853]: Browsing: connect error: Connection

● bluetooth.target - Bluetooth
   Loaded: loaded (/lib/systemd/system/bluetooth.target; static; vendor preset: 
   Active: active since Sat 2020-04-04 18:46:32 CEST; 39min ago
     Docs: man:systemd.special(7)
  • Just to clarify - is this Debian or Raspbian Buster / 10? – Andyroo Apr 4 at 19:49
0

Is a Debian Buster, upgraded from Stretch, However I resolved for this with a new clear installation of Debian 10 (it was not the only problem...), although the headset are seen as output and input device. Thanks!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.