2

I'm looking to install Atom on my Raspberry pi 4. In ARMHF naturally.
I have already tried a lot of solution, but nothing works.
I tried the atom-arhmf.deb from the official github repository and followed: Installing Atom text editor on Rasberry Pi and Installing Atom text editor on Rasberry Pi unfortunately without result .

Can someone refer me?

  • 1
    Can you post any error message you see or explain what is going wrong a bit more please? – Andyroo Apr 6 at 16:47
0

I have been affected by Atom problems on my Raspberry Pi 4B too.

I am reposting a question that I submitted to Linux Questions yesterday. Today's reply to that question was about the Package Cloud web site's Raspbian repository possibly being down.

https://www.linuxquestions.org/questions/debian-26/apt-get-update-raspberry-pi-4b-debian-10-buster-raspbian-missing-release-file-in-packagecloud-io-atomeditor-dependency-4175675145/

apt-get update - Raspberry Pi 4B - Debian 10 Buster - raspbian - missing Release file in packagecloud.io AtomEditor dependency? Good afternoon (from the UK). This is my first post in Linux Questions.

I have a Raspberry Pi 4B as stated in the Subject, with 4GB RAM, 32 GB SD card.

I had problems with sources.list in /etc/apt - RESOLVED - these were caused by me splitting a line when trying to install VS Code on the Pi.

However, apt-get update does not complete, and I consequently cannot successfully install the GNS3 Network Simulator on the Pi.

THIS IS MY sources.list file content:

Code:

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

Uncomment line below then 'apt-get update' to enable 'apt-get source'

deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

This is my terminal activity when I tried apt-get update (as root user; I am still new to Linux computers as opposed to virtualization in Windows, Visual Studio Code):

The problem appears to be with PackageCloud.io. I have been to that site, including the address in red ("The page you were looking for doesn't exist.")

Code:

pi sources.list.d
$ sudo su   
root@raspberrypi:/etc/apt/sources.list.d# apt-get update
Hit:1 http://ppa.launchpad.net/gns3/ppa/ubuntu xenial InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Ign:3 https://packagecloud.io/AtomEditor/atom/raspbian buster InRelease        
Get:4 https://packagecloud.io/AtomEditor/atom/any any InRelease [23.2 kB]
Hit:5 https://packagecloud.io/headmelted/codebuilds/debian stretch InRelease
Err:6 https://packagecloud.io/AtomEditor/atom/raspbian buster Release 
  404  Not Found [IP: 52.52.201.17 443]
Get:7 https://packagecloud.io/AtomEditor/atom/any any/main amd64 Packages [30.0 kB]
Get:8 http://archive.raspberrypi.org/debian buster InRelease [25.1 kB]
Get:9 http://archive.raspberrypi.org/debian buster/main Sources [92.1 kB]
Get:10 http://archive.raspberrypi.org/debian buster/main armhf Packages [327 kB]
Reading package lists... Done                                                  
E: The repository 'https://packagecloud.io/AtomEditor/atom/raspbian buster Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Contents of /etc/apt

Code:

root@raspberrypi:/etc/apt# ls
apt.conf.d   listchanges.conf  sources.list    sources.list.save  trusted.gpg~
auth.conf.d  preferences.d     sources.list.d  trusted.gpg    trusted.gpg.d

Contents of /etc/apt/sources.list.d

Code:

root@raspberrypi:/etc/apt/sources.list.d# ls
AtomEditor_atom.list  atom.list  atom.list.save  gns3.list  headmelted_vscode.list  raspi.list

atom.list.save is the result of me repeatedly editing atom.list in the Nano editor in the LX Terminal.

Text of atom.list

Code:

deb [arch=amd64] https://packagecloud.io/AtomEditor/atom/any/ any main

Text of AtomEditor_atom.list

# this file was generated by packagecloud.io for
# the repository at https://packagecloud.io/AtomEditor/atom

Code:

deb https://packagecloud.io/AtomEditor/atom/raspbian/ buster main
deb-src https://packagecloud.io/AtomEditor/atom/raspbian/ buster main

linux 
| improve this answer | |
  • AMD64 is the wrong architecture. The Raspberry Pi is either ARMHF or AARCH64. – Dougie May 15 at 0:02
  • Thank you very much! Thanks to your reply, I have just amended atom.list now to armhf instead of amd64! – Ben Hughes May 21 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.