1

I have an issue with apt-get and any script I will call python3 on my Raspberry running Raspbian Buster.

When I run apt-get upgrade (or apt-get dist-upgrade or apt full-upgrade) this happends every time:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libgnutls30
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,047 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
/usr/bin/python3: relocation error: /usr/bin/python3: symbol `Up version GLIBC_2.4 not defined in file libc.so.6 with link time reference
E: Sub-process /usr/bin/apt-listchanges --apt || test $? -lt 10 returned an error code (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10

apt-get update completes successfully

I was looking around it and I found out that when I run python3 it outpus this:

python3: relocation error: python3: symbol `Up version GLIBC_2.4 not defined in file libc.so.6 with link time reference

I compared some stuff between my two raspberry pi's.

The variable $GLIBC_2.4 contains the value ".4" in both systems,

The python executables in /usr/bin/ are exactly the same in both systems.

And also the files and their symbolic links are exactly the same in the directory /lib/arm-linux-gnueabihf/

Is there anything else I can check so I can figure out what is happenning?

Thank you in advance!

UPDATE:

Some additional information I just figured out from the logs. The last package I installed was "tmux".

Start-Date: 2020-04-06  08:13:51
Commandline: apt-get install tmux
Requested-By: llouk (1000)
Install: libutempter0:armhf (1.1.6-3, automatic), tmux:armhf (2.8-3)
End-Date: 2020-04-06  08:14:03

Tmux or it's dependency triggered a change in libc-bin

Log started: 2020-04-06  08:13:51
Selecting previously unselected package libutempter0:armhf.
(Reading database ... 160347 files and directories currently installed.)
Preparing to unpack .../libutempter0_1.1.6-3_armhf.deb ...    
Unpacking libutempter0:armhf (1.1.6-3) ... 
Selecting previously unselected package tmux.
Preparing to unpack .../archives/tmux_2.8-3_armhf.deb ...
Unpacking tmux (2.8-3) ...
Setting up libutempter0:armhf (1.1.6-3) ...
Setting up tmux (2.8-3) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...
Log ended: 2020-04-06  08:14:03
  • We have no way of knowing how your system has become corrupt. The safest thing to do is to reinstall, – joan Apr 7 at 19:55
  • I hope to figure it out, cause that configuration again with take days.. – llouk Apr 7 at 19:57
1

It seems that your python3 installation is broken. There cannot said much with the available information what has gone wrong. You can try to reinstall python in the hope this will fix the broken installation. Try this:

rpi ~$ sudo apt install --reinstall python3

You may have a look at other installed python packages and consider to also reinstall them:

rpi ~$ sudo apt list --installed *python3*
| improve this answer | |
  • Thank for the answer! Yes, it was broken! Those commands above was failing cause python3 was not able to run. I got some help to fix it, I will post an answer of what I did – llouk Apr 10 at 17:39
1

I got some help, and finally figure it out! I will explain what was wrong, and what I did to fix it.

The /usr/bin/python3 executable on the broken system was corrupt. Specifically the symbol "dup" has two bit errors, one changing the "d" to a backtick, and one changing the case of the "u".

So, I copied python3 from a another working raspberry, and it fixed the error.

Then, I run:

sudo apt install debsums
sudo debsums -c

And found more corrupted files on that system, and afterwards re-install any package with corrupted files using:

dpkg -S FILE
sudo apt install --reininstall PACKAGE

All that thanks to jojopi, in the post below

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=270228&p=1639714

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.