2

I'm following this guide: https://www.cnx-software.com/2019/07/26/how-to-overclock-raspberry-pi-4/

And when I run the command vcgencmd get_config int | grep "arm\|over" it tells me that arm_freq=1400.

Why is that? And how can I properly overclock my RPi 4?

Edit 2:

My OS is Raspbian Buster

Edit 1:

Some more info: rpi-update gives me this

 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Your firmware is already up to date

And sudo apt dist-upgrade gives me this

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

My /boot/config.txt looks like this

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=51

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
force_turbo=0
arm_freq=2000
over_voltage=6

[all]
#dtoverlay=vc4-fkms-v3d
  • Is the firmware and O/S up to date? – Andyroo Apr 9 at 23:27
  • 1
    that is odd, because without messing around at all, arm_freq=1500 - so you managed to slow it down - so, what does your /boot/config.txt look like? – Jaromanda X Apr 9 at 23:40
  • @Andyroo yes. I updated my question with more information, please read. – vaid Apr 10 at 0:04
  • @JaromandaX huh? I underclocked it? haha. I updated my question with full config.txt content. – vaid Apr 10 at 0:05
  • 1
    Baffled - it may be worth moving the overclock away from the Pi 4 tag (guess) and starting at a lower value (say 1450) then step up This post from Jan raspberrypi.org/forums/… infers not all Pis overclock to the same top speed. (Bed time for me it’s gone 4AM) – Andyroo Apr 10 at 3:14
2

Moving the overclock configuration from section [pi4] to section [all] fixed it.

Although my RPi seems to not be stable when overclocking over 1600 MHz.

| improve this answer | |
1

Try

over_voltage=4
arm_freq=2001
arm_freq_min=400
#arm_64bit=1

Uncomment the last line if you are running a 64bit O/S

| improve this answer | |
  • No go. Tried with and without the last line. – vaid Apr 10 at 1:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.