1

I've connected a Raspberry Pi Camera v2.1 to a Raspberry Pi 3 B+. I've enabled the camera interface.

Using

pi@raspberrypi:~ $ raspistill -v -o test.jpg

raspistill Camera App v1.3.11

Width 3280, Height 2464, quality 85, filename test.jpg
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled  no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Flicker Avoid Mode 'off'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
Camera component done
Encoder component done
Starting component connection stage
Connecting camera preview port to video render.
Connecting camera stills port to encoder input port
Opening output file test.jpg
Enabling encoder output port
Starting capture -1
Finished capture -1
Closing down
Close down completed, all components disconnected, disabled and destroyed

The resulting image looks like this:

Picture preview

I've tried various things but to no avail. It always looks like this. Is this module broken? I have no other module to try, unfortunately.

3
  • Power everything off. Re-seat the ribbon cable. Reboot and retest. It does look like you've got a broken piece of hardware. – Dougie Apr 10 '20 at 15:39
  • @Dougie I've tried that, same result. – Ben Apr 10 '20 at 15:46
  • Send the camera back for an RMA. – Dougie Apr 10 '20 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.