I'm attempting to put Raspbian Jessie on an SD card. (I'm choosing Jessie to eliminate a possibility of incompatibilities with the SW I plan on using. I may use Buster after getting everything working with Jessie first.)

I'm using Raspberry Pi Imager 1.2 and a Jessie image from http://downloads.raspberrypi.org/raspbian/images/

First I tried the 2017-07-05 version of Jessie, which I believe is the last. I choose the unzipped img file and card to write to, then select "WRITE". I then receive the following error:

Raspberry Pi Imager error - Input file is not a valid disk image "Input file is not a valid disk image. File size [X] bytes is not a multiple of 512 bytes."

I then tried the 2017-06-21 version and got the same result. I verified the checksum of both downloaded zip files.

When using the 2020-02-14 version of Buster from that same image directory, the Imager accepts it.

I take it I'm either doing this wrong, or the the Raspian images made before the existence of the Pi Imager are simply not compatible. Which is it?

  • 1
    I've had the same message with Buster (inc sha-256 being OK) and gone back to Etcher - think I should not have left TBH :-)
    – user115418
    Commented Apr 11, 2020 at 16:10
  • 1
    The latest image of Jessie that I have is 2017-03-02. I tried it with the Raspberry Pi Imager and it worked just fine. "2017-03-02-raspbian-jessie.img has been written to Mass Storage Device USB Device. You can now remove the SD card from the reader."
    – Paul
    Commented Apr 11, 2020 at 16:50
  • 1
    I just posted the answer. Glad you got it to work!
    – Paul
    Commented Apr 11, 2020 at 17:35
  • 1
    Why do I have multiple downvotes with no explanation? Am I supposed to just guess what's wrong with my question??
    – Bort
    Commented Apr 12, 2020 at 17:38
  • 1
    @CoderMike - I'm trying to use OpenCV in conjunction with a bunch of scripts I wrote in 2017. I tried using the latest everything (Buster, OpenCV4, Python3, etc) and ran in to a bunch of issues. Time is a factor, so first I'm going use something that I know works. Then I'll focus on how to update my scripts and update my builds to work together.
    – Bort
    Commented Apr 13, 2020 at 12:34

3 Answers 3


At one time the Foundation distributed images with an incomplete last block.

This caused some poorly written image programs to fail.

The Foundation has since learned the error of its ways but apparently not when writing new imagers.

If you want to waste your time with obsolete OS you will find discussions on this site - and work arounds for dd.


User Paul showed that the 2017-03-02 image of Jessie actually works.

The latest version I was able to get working was the very next version: 2017-04-10

Any Jessie images after 2017-07-05 appear to fail in the same manner.

  • 1
    It was actually 2017-03-02 that I got to work. I assume that's what you meant.
    – Paul
    Commented Apr 11, 2020 at 18:48
  • 1
    Good to know that other images work.. Wonder why other images fail if they are not a multiple of 512 bytes.
    – Paul
    Commented Apr 11, 2020 at 18:59
  • 1
    @Paul - Oops, I can't even copy and paste right! I'm assuming the 512 multiple requirement has to do with "block"/sector sizes on SD cards. Since these files are disk images, they are expected to fit perfectly in to a set amount of space.
    – Bort
    Commented Apr 11, 2020 at 19:14
  • 1
    No. It's just an arbitrary limitation imposed by the "Pi imager". If you have a machine where you can run dd, that method will work with any image that's actually an image regardless of the size. You have an XY problem here -- although if you are fine using that one image that works, it doesn't matter. Note you could also take any of the images and resize it slightly to work by mounting the root fs partition, creating a new one of the right size, copying the content in, and using that in a new image file.
    – goldilocks
    Commented Apr 11, 2020 at 19:30

If you really need the old image, then use Rufus (https://rufus.ie/) or balenaEtcher (https://www.balena.io/etcher/). Both have worked without fail ever since I started using RPi. Hope that helps!

Not the answer you're looking for? Browse other questions tagged or ask your own question.