0

I am able to ssh into the Raspberry with an ethernet cable from RPi to router. I am also able to use my mobile as a hotspot and find the RPis ip and ssh into it!

But it does not work if I try to use my home-network! The RPi is connected to the wifi, works to ping google.com and also router but i can't ping my laptop or any others. I can't ping the RPi from my laptop and I can't find the RPis IP-address in the network (tried Advanced IP-scaner, nmap, Fing and so on).

RPi ip: 192.168.128.115 (found by connecting monitor), my laptop ip: 192.168.128.123

>ping 192.168.128.115

Pinging 192.168.128.115 with 32 bytes of data:
Reply from 192.168.128.123: Destination host unreachable.
Reply from 192.168.128.123: Destination host unreachable.
Reply from 192.168.128.123: Destination host unreachable.
Reply from 192.168.128.123: Destination host unreachable.

Ping statistics for 192.168.128.115:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

I have checked so that the RPi is listening on port 22. Seems like the router does not allow any connection to be setup between the devices, and doesn't allow the Pi to be found in the network. Can someone please help me, I have googled and tried everything and can't find any forums with a solution to exactly this problem, most of them are unresolved.

EDIT: The it-guy set up a 1:1 NAT rule in the firewall to route all traffic for 10.0.0.10 to 192.168.128.115 (the RPis ip) so now I can SSH into it! But the Pi does not reach the internet.. They are having problems fixing this, any tips?

4
  • 1
    This is most likely a problem with your (unusual) network - not the Pi. Post the output of ip r, but without a clear description of you network who knows?
    – Milliways
    Apr 13, 2020 at 6:58
  • This may be because the wired and wireless connections have different IP addresses, as they are different devices. What does running the command sudo ifconfig output? Apr 13, 2020 at 13:01
  • 1
    Some routers stop connections between devices (esp those on WiFi) - on my router it’s called ‘client isolation’. It would help if we knew what your router and any switches are.
    – user115418
    Apr 13, 2020 at 17:36
  • Router: MERAKI MX64
    – EllinorR
    Apr 23, 2020 at 2:32

1 Answer 1

1

Some router have a security setting that prevents communication between wireless attached devices. Mostly this is configurable on the router but enabled (blocking) by default. On my router in the wireless configuration section it is called: "Wireless -> Security -> The active wireless devices displayed below may communicate with each other? - yes|no". You should check your router if you can also modify a similar setting. If not, you may consider to get another router, at least for testing.

1
  • it seems most likely, I am waiting for the login to my student apartments router, I'll let you know when i've tried this
    – EllinorR
    Apr 17, 2020 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.