1

I am having trouble changing my default mic on raspbian buster lite (kernel 4.19.36 on the 3B+). I know that the mic is fully functional because when I run: arecord -D plughw:1,0 --duration=3 test.wav && aplay test.wav it records and plays back my audio just fine. My issue is that this microphone is not the default. My results from running arecord -l :

**** List of CAPTURE Hardware Devices ****
card 1: Device [USB PnP Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I have tried changing my .asoundrd and my /etc/asound.config file to:

pcm.!default {
type asym
playback.pcm "plughw:0"
capture.pcm  "plughw:1"
}

ctl.!default {
    type hw
    card 1
}

I have tried changing the lines from my /usr/share/alsa file from defaults.ctl.card 0 defaults.pcm.card 0 to defaults.ctl.card 1 defaults.pcm.card 1

None of the above mentioned solutions have worked for me.

The reason why I am trying to change my default microphone is because I am developing a python project that uses the Snowboy Hotword Engine, and I have not been able to find a way to get it to reference a different mic. So, if anyone knows how to do that, I don't actually need to change the default mic.

Thank you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.