0

Given the vast address space available for IoT devices using IPv6, I was doing some testing and ran into some funky, inconsistent behaviour regarding address configuration.

In Raspbian Buster, I persistently set in /etc/sysctl.conf the preference to disable Privacy Extensions (RFC 4941):

net.ipv6.conf.default.use_tempaddr=0

However, instead of an EUI-64 constructed address, on boot I get an address configured using privacy extensions? Why are the persistent sysctl setting ignored?

1

The directives in /etc/dhcpcd.conf override IPv6 Privacy Extensions preferences set persistently in /etc/sysctl.conf

To DISABLE Privacy Extensions:

To configure an EUI-64 formatted IPv6 address, in /etc/dhcpcd.conf set the respective directives as follows:

#slaac private
slaac hwaddr

To ENABLE Privacy Extensions:

Conversely, invert the preferences to get an interface configured USING IPv6 Privacy Extensions:

slaac private
#slaac hwaddr

Hope this saves others similar head scratching when configuring host address configuration for IPv6-

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.