2

Recently I experienced a breakdown of the SD card on a Raspberry Pi 3 B (no B+) I use as a courtesy PC for my nieces/nephews. Since I had two SDHC 8GB cards, I did not worry too much and

  1. Downloaded the Raspberry Pi Imager for macOS.
  2. Wrote Raspbian Buster with desktop on the SHDC card (a Micro SD Kingston).
  3. Inserted the OS card in the Raspberry slot and installed Raspbian buster: to be sure of successful operation I rebooted the system a couple of times and it worked fine.

Then, just as a final proof-of-success, I powered off the Raspberry, turned off the power supply, waited a few minutes and then turned it on again: the system did not boot. I though it was a problem of the SDHC card therefore I repeated the same three steps, but the result was the same! So, thinking the board was damaged, I brought from my lab another Raspberry Pi 3 Model B (I never used it as I kept it as a spare part): however, after repeating the three steps above, I got the same results: the Raspberry does not boot after turning the power supply off.
After these test, I

  1. Formatted again the SDHC cards and repeated the three steps above by downloading directly the Raspbian buster and writing it on the cards by using balenaEtcher: same result.
  2. Tried to use an older Raspbian version, precisely the 2018-11-13-raspbian-stretch: same result.
  3. Changed the power supply (I have a couple of original Raspberry +5V power supplies explicitly designed for the Pi 3 Model B): same result.

Now, my fateful final question is: why Raspbian does not boot after seemingly having been correctly installed?

7
  • First boot always takes longer (up to 5 mins in the case of the last Zero I built) - have you left it for awhile?
    – user115418
    Apr 14 '20 at 15:23
  • @Andyroo, yes. Sometime I left the device powered for at least half an hour, being busy on other activities. However, I was not able to see anything. Apr 14 '20 at 15:28
  • Did you 'shutdown' before powering off? I would suggest using at least 16GB cards, 8GB must be close to the limit for Raspbian Buster?
    – CoderMike
    Apr 14 '20 at 15:28
  • @CoderMike Yes, I shutdown the system and then turned off the power supply. And I purchased yesterday a few 32 Gb cards in order to test again the installation: however note that I tried also Raspbian Stretch, therefore I doubt that the limited capacity of the disk could be the cause of the problem. Apr 14 '20 at 15:40
  • 1
    the fact that multiple SD cards on multiple pi's with multiple power supplies using multiple images written using multiple imagers all behave the same points to one single unchanged point of failure - so, when it fails, does the ACT led flash a particular number of times? Apr 14 '20 at 23:25
2

This is the culprit: enter image description here

This HDMI-to-VGA converter (the only object I have not changed during my many tests, and thanks to @Ingo for having opened my eyes on this) does not allow the automatic recognition of the monitor by the Raspberry. To solve the problem, I proceeded as described in this post. Precisely,

  1. Since I use Raspbian, I accessed the boot partition of the SD card and then opened the config.txt file,
  2. I uncommented the line hdmi_force_unplug=1 to force the HDMI mode and added the following ones.
hdmi_ignore_edid=0xa5000080
hdmi_drive=2
hdmi_group=2
hdmi_mode=35
  1. Put the SD card with the modified config.txt file into the Raspberry.

And the monitor is perfectly driven since then.

Edit: further experiments with newer Raspberry Pi models. In these months I also experimented with new versions of the Raspberry, in order to enhance the performance of the courtesy PC but also to see if they inherit the same problem: precisely I used

  • a Raspberry Pi 3 B+ and
  • a Raspberry Pi 4 B with 4Gb RAM.

I was able to install Raspbian on them without having to do the above workaround in order to drive the same old SVGA LCD Monitors: therefore it seems that this problem exists only for Raspberry Pi 3 B or older models.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.