3

I've got a Raspberry Pi 2 I'm trying to install a TP-Link TL-WN823N V2 onto.

pi@raspberrypi:~ $ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

pi@raspberrypi:~ $ lsusb
Bus 001 Device 005: ID 2357:0109 TP-Link TL WN823N RTL8192EU
Bus 001 Device 004: ID 1997:2433  
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I've tried the other tutorials and nothing seems to work.

Can anyone help

5
  • sudo http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi; then sudo chmod +x /usr/bin/install-wifi; then sudo install-wifi -u; – Dougie Apr 14 '20 at 19:20
  • @Dougie HTTP could serve you anything at all on that URL, depending on the network you're connected to. I would at least go for HTTPS. – Dmitry Grigoryev Oct 16 '20 at 15:40
  • @DmitryGrigoryev it ain't my code. It ain't my website. It belongs to the guy on the Raspberry Pi Forum who builds all the drivers for the out-of-tree WiFi adapters. – Dougie Oct 17 '20 at 10:28
  • @Dougie My point is that a website served through HTTP can contain anything, including viruses and exploits, depending on the network you're connected to. That's why HTTPS exists: your provider can serve you the real data, or nothing at all, but not a fake page. – Dmitry Grigoryev Oct 17 '20 at 20:39
  • @DmitryGrigoryev to be honest I don't give a flying. It's not mine. I can't change it. I really don't care a toss. – Dougie Oct 18 '20 at 0:38
3

Found the working fix for this:

First, create directory to keep the driver source files in a common place if you don’t have it already.

mkdir drivers && cd drivers

I used latest Raspbian Jessie released on 5th of July 2017. For me it required only to install kernel header files as shown below.

sudo apt-get install raspberrypi-kernel-headers dkms

Get the driver source files hosted at github repo https://github.com/Mange/rtl8192eu-linux-driver. The driver source seems like for D-Link DWA-131, which is having same chipset, rtl8192eu, as my TP-Link TL-WN823N v2.

We have to clone realtek-4.4.x branch, which is for Linux kernel 4.4. However it worked for my Raspbian having kernel version 4.9.35.

git clone --branch realtek-4.4.x https://github.com/Mange/rtl8192eu-linux-driver.git

By default the building process will target desktop systems. We have to change that, to build the driver for Raspberry Pi.

You will see Makefile within driver source directory you just cloned above. Open it in a text editor. You can find following line:

CONFIG_PLATFORM_I386_PC = y

Change it to:

CONFIG_PLATFORM_I386_PC = n

Then find following line. If your Makefile does not contain the line below, then just copy and paste in directly below the line above in your file ensuring to remember to change the flag from n to y

CONFIG_PLATFORM_ARM_RPI = n

Change it to:

CONFIG_PLATFORM_ARM_RPI = y

Now we can build and install the driver.

cd rtl8192eu-linux-driver/
sudo dkms add .
sudo dkms install rtl8192eu/1.0
sudo reboot

If everything went well, then WiFi adapter should get detected once you restart networking service or reboot Pi.

This solution is originally from: https://blog.junix.in/2017/07/11/tl-wn823n-driver-in-raspberry-pi-2-b/

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Apr 22 '20 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.