-1

I copied the latest (April 18th) Raspbian lite image to a 32 GB SD card with Imager. Then I created an empty ssh file and the wpa_supplicant.conf file with ssid and psk as I use them on my laptop. After booting the pi I tried to ping (from Mac or Linux) it but:

ping: cannot resolve pi@raspberrypi.local: Unknown host

Here the file:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=DE

network={
 ssid="myNet"
 psk="xxx"
}

What could be missing? Thanks for any help

  • 1
    You should not include the user id in the ping. Try ping raspberrypi.local. – Dirk Apr 18 '20 at 12:14
  • Then I created an ssh folder 0 you mean empty file? I wonder if having a folder would actually work? and the wpa_supplicant.conf file with said and psk as I use them on my laptop - in the correct format, right? – Jaromanda X Apr 18 '20 at 13:39
  • Sorry, I created an empty ssh file (touch /Volumes/boot/ssh) And removing pi@ didn't help – geistgesicht Apr 18 '20 at 13:49
  • Does the router show the Pi connected? Did you put the country code in the wpa_supplicant file? It may be best if you show the file here with the SSID and password replaced with x - leave all quotes etc as is and edit the question using the code option so we can see the actual layout please. Are you trying to connect from a Mac, PC or Linux box? – user115418 Apr 18 '20 at 14:11
  • The pi doesn't show up in the router. Here the file: ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 country=DE network={ ssid="myNet" psk="xxx" } The file has the correct line breaks as in [raspberrypi.org/documentation/configuration/wireless/… – geistgesicht Apr 18 '20 at 14:25
0

If you can log on to the Pi, try executing this command:

rfkill list all

You may see something like this:

0: phy0: Wireless LAN

  Soft blocked: yes

  Hard blocked: no

1: hci0: Bluetooth

  Soft blocked: yes

  Hard blocked: no

A hard block is caused by a hardware switch, which I don't think the Pi has. A soft block can be removed with:

rfkill unblock wifi

This worked for me, even after a reboot. I got the hint from https://askubuntu.com/questions/566799/wifi-soft-blocked-by-rfkill-on-startup

0

I found out that model B+ V 1.2 doesn't have a WIFI chip 😬

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Apr 27 '20 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.