1

I have a custom buildroot image for RPi 0w. Initial experiments went well, however as soon as I added udev package to buildroot something strange happened to console output. I can see the whole log from booting and everything seems to get up without errors. At the end of the boot, I cannot input anything into serial (via putty) so I'm effectively locked away from the system.

I tried adding /etc/securetty file but it did not help. I have getty console enabled in menuconfig and in /etc/inittab, my cmdline.txt. looks like this:

root=/dev/mmcblk0p2 rootwait console=serial0,115200 console=tty1

Those settings worked previously, so I assume this has something to do with udev.

I assume I have to change something in configuration, but there is so much of it that I feel overwhelmed.

1

I've found solution here: http://buildroot-busybox.2317881.n4.nabble.com/BuildRoot-not-starting-with-Udev-td33140.html

Udev requires re configuring kernel because new DEVTMPFS is needed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.