I'm using a Raspberry Pi 3 model B+ together with a Waveshare touch screen model 7inch HDMI LCD (C) which claims to be “low consumption,” although gives no precise amperage of the device.

Anyway, sometimes the Raspberry Pi boots correctly, but more often than not (say nine times out of ten) it shows a lot of USB-related errors in syslog, and the monitor is powered correctly, but the touch part doesn't work.

The errors look like this:

usb 1-1.3: device not accepting address 14, error -32
usb 1-1-port3: unable to enumerate USB device


usb 1-1.3: device descriptor read/64, error -32
usb 1-1-port3: attempt power cycle

Searching through the Internet, I find a lot of resources suggesting three things.

  • Some claim that the fault is the power supply. I tried to power the Raspberry Pi with (1) a 2.4A charger, (2) a 3A charger, and (3) a 5V 12A power supply. While I understand that a 2.4A charger may not be ideal, the 12A PSU should be largely enough. I also tested different USB cables.

  • Others suggest to put one or all options among dwc_otg.fiq_fsm_enable=0, dwc_otg.fiq_enable=0, and dwc_otg.nak_holdoff=0. I tried to put all three, although I cannot find any relevant information about what those options are, and don't know what they really do. Anyway, I observed no difference.

  • Others assert that it is “triggered when power consumption from the port is too high.” Possible, although I'm surprised that a few LEDs for screen backlighting and the touch itself is too much for Raspberry Pi (as the screen itself gets its main power rather through HDMI).

  • Also, there are mentions of other reasons, such as a wrong frequency or damaged USB device. Regarding the frequency, I did the test with another, brand new Raspberry Pi 3 B+, and the result is still the same. Damaged touch screen? Possible, but weird.

  • Finally, a few resources mention max_usb_current=1 setting in /boot/config.txt. I already have this setting, given that I'm not sure if I should, after all.

So, what are my options?

  • Did you ever find a solution to this problem? Commented May 19, 2021 at 9:43
  • @PierrePretorius: not really. The current “solution” in my case is to turn the power off and back on, until the touch screen starts working. I thought about providing the external power to the monitor, but didn't do it yet. Commented May 19, 2021 at 13:05
  • another case when such message appear: if the USB connector/cable has been dedicated for UART or other non-managed interface instead. some companies do such strange things over USB connector/cable Commented Jul 1 at 6:57

1 Answer 1


I was getting this also. Resolved with a different cable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.