I am using a Vilros Raspberry Pi 4 with Raspbian. The RPi works, but every time I boot the system, nothing shows up on my monitor (resolution 2048x1080), just a black screen. I can blindly enter my credentials, then run startx, then the GUI shows up no problem on my monitor and everything is good.

This happens when I start the RPi with everything (keyboard, mouse, monitor) already plugged in, monitor in HDMI 0. When I boot the RPi without the monitor plugged in, then plug it in once its ready to go, I can see the boot screen/terminal, but the resolution is bad because the system used some other poorer resolution than 2K.

List of all the things I've tried (which failed): Going into /boot/config.txt and setting (at different times):

  • disable_overscan=1

  • framebuffer_width=2048

  • framebuffer_height=1080

  • config_hdmi_boost=4.

  • also, hdmi_force_hotplug=1 by default from NOOBS, so that is already set.

I also tried hitting enter/typing in gibberish to the black screen, but that gave me nothing. If anyone could help me out with this problem, it would be much appreciated.

  • Thats a weird resolution. I would not use Noobs, flash 'Raspbian Buster with Desktop' direct to sd card with Etcher. More likely to detect your screen properly.
    – CoderMike
    Apr 21, 2020 at 21:09

1 Answer 1


I was able to resolve my problem by running

sudo raspi-config

then using advanced options -> resolution, and setting my resolution to DMT 1920x1080p.

In /boot/config.txt, this sets:



This was for a Viotek FI24D monitor which has a resolution of 2560x1440p.

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Apr 24, 2020 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.