1

I seem to went the same path as described in "Connecting Raspberry Pi 3 with Huawei Surfstick 372". Bellow are the details of my case.

WHEN on wi-fi

The command ip addr show returns:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:04:34:b2 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:51:61:e7 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.108/24 brd 255.255.255.255 scope global noprefixroute wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::8ef:c3cc:ab76:6893/64 scope link 
       valid_lft forever preferred_lft forever
4: wwan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    link/ether 00:1e:10:1f:00:00 brd ff:ff:ff:ff:ff:ff
    inet 169.254.62.145/16 brd 169.254.255.255 scope global noprefixroute wwan0
       valid_lft forever preferred_lft forever
    inet6 fe80::a2e6:a0b0:c3ed:c6f5/64 scope link 
       valid_lft forever preferred_lft forever

And the command ip route show returns:

default via 192.168.0.1 dev wlan0 proto dhcp src 192.168.0.108 metric 303 mtu 576 
169.254.0.0/16 dev wwan0 scope link src 169.254.62.145 metric 204 
192.168.0.0/24 dev wlan0 proto dhcp scope link src 192.168.0.108 metric 303 mtu 576 

WHEN NOT on wi-fi

The command ip addr show returns:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:04:34:b2 brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:51:61:e7 brd ff:ff:ff:ff:ff:ff
4: wwan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    link/ether 00:1e:10:1f:00:00 brd ff:ff:ff:ff:ff:ff
    inet 169.254.62.145/16 brd 169.254.255.255 scope global noprefixroute wwan0
       valid_lft forever preferred_lft forever
    inet6 fe80::a2e6:a0b0:c3ed:c6f5/64 scope link 
       valid_lft forever preferred_lft forever

And the command ip route show returns:

default dev wwan0 scope link src 169.254.62.145 metric 204 
169.254.0.0/16 dev wwan0 scope link src 169.254.62.145 metric 204 

So it's according the abovementioned story not routed properly - there is no via. According to this post it is in the W10 operating in "HiLink mode" rather than the "Stick mode". I simply don't know what else to try with E3531 getting connected. Can anyone advise please? Thanks, Tomas, Pilsen, Czech

Note: I tried the surfstick in W10. Thanks to the retailer's program from O2 it actually got me connected (O2 just sells Huawei stick, but in this case it's not the internet service provider). The provider (the SIM card issuer) is SazkaMobil (a virtual operator).

As I'm reading imense amounts of posts I'm getting to a conclusion that connecting a USB stick is just not a good way. The more I dive into it the more unknowns emerge. Articles about it are outdated. My stick E3531 seems to have at least three modes:

12d1:15e7 = windows install mode virtual cdrom
12d1:15ca = usb storage (this is the default mode after start)
12d1:1506 = likely HiLink = Huawei's router with the 192.168.1 webpage. But that's not a modem according to some posts. And this is where it ends after the usb_modeswitch which supposedly switches from USB storage to the desired modem mode.
4
  • 1
    When you are connected to the WiFi then the default route is set to wlan0 so you will have internet access on the WiFi. For what do you need the E3531 with interface wwan0?
    – Ingo
    Apr 23, 2020 at 9:44
  • hi @Ingo thanks for a prompt response. My goal is to get RPI to a cabin and run data over GPRS. It's for the PrivateEye "boxed" security system. On wifi it worksNext the GPIO peripheralsand finally the camera and MQTT (for plants watering, temps, water levels) and having all accesible from home. I'm a newbie to Linux, Python coding and networking as well. Is the USB stick actually a better (understand - easier to setup) choice above the classical wired modem? Yet with my current level of expertise best option is following a step by step guide
    – mtnlion81
    Apr 24, 2020 at 12:23
  • I still do not understand your problem. Everything in your setup looks as expected. If WiFi is up then you are connected to internet by it (default route set on wlan0). If WiFi is down the the default route is set on wwan0 and internet connection goes through that. What do you want to achieve? Using always the wwan0 interface for internet access, no matter if wlan0 is up or down?
    – Ingo
    Apr 24, 2020 at 17:30
  • @Ingo what you describe is what I expected. I should have described it at the original post - the issue is the Wwan0 doesn't get me connected to the internet (browser). I'm missing a detail of what files or setups to check. Only thing I saw different from the mentioned link was missing the "via". In detail then: "It does not have a gateway ip address. It should look something like this: default via 10.20.30.1 dev wwan0 proto kernel scope link src 10.20.30.40 metric 204 ". And if that's also my case I'd need to find out how to define the gateway.
    – mtnlion81
    Apr 26, 2020 at 11:43

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.