1

I have created a network using a wifi router with 2 raspberry pi devices (stretch OS) and one windows 10 machine.

Windows ipconfig:

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::f0cf:c120:e272:5687%12
   IPv4 Address. . . . . . . . . . . : 190.160.1.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 190.160.1.1

RPI device -1

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:ed:64:ff  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 28  bytes 2372 (2.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28  bytes 2372 (2.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 190.160.1.101  netmask 255.255.255.0  broadcast 190.160.1.255
        inet6 fe80::eeaf:3b9d:fb9a:bf4f  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:b8:31:aa  txqueuelen 1000  (Ethernet)
        RX packets 518  bytes 58281 (56.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 394  bytes 49746 (48.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

dhcpd.conf file for device 1

interface wlan0
static ip_address=190.160.1.101/24
static routers=190.160.1.1

RPI device -2

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:47:b2:bb  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 9  bytes 524 (524.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9  bytes 524 (524.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 190.160.1.102  netmask 255.255.255.0  broadcast 190.160.1.255
        inet6 fe80::fbc5:984d:503a:4ced  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:12:e7:ee  txqueuelen 1000  (Ethernet)
        RX packets 460  bytes 55329 (54.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 344  bytes 54512 (53.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

dhcpd.conf file for device 2

interface wlan0
static ip_address=190.160.1.102/24
static routers=190.160.1.1

/etc/network/interfaces for both RPI 1 and 2 are empty

I could ping the raspberry pi devices from the windows machine and can ssh the same. both raspberry pi device can ping each other too.

PROBLEM IS

I couldn't ping windows machine from the raspberry pi even though I took ssh from the windows machine.

I couldn't figure out what I am missing. If you need more detail please comment.

Edit: enabled the firewall rules as per Harvey's answer

But still the ping from raspberry is not getting reply.

1

You are using public ip addresses from 190.160.1.0/24 for your private local area network. Never do that, except you have rent this subnet from your internet provider for public use! It may confuse the router. Use instead reserved ip addresses for private networks, e.g. 192.168.1.0/24. This is the first step to reduce possible problems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.