2

Hardware:

Pi-4 OS -raspbian

I followed the following guide :https://www.raspberrypi.org/documentation/configuration/wireless/access-point-routed.md

Now it works great , I could Connect to the hot spot until I restarted the PI then Im receiving error on my phone "Couldnt get IP Address"

If I try wrong Password I do get wrong password error.

Files:

 dnsmasq.conf:

interface=wlan0 # Listening interface

dhcp-range=192.168.4.2,192.168.4.20,255.255.255.0,24h

                # Pool of IP addresses served via DHCP

domain=wlan     # Local wireless DNS domain

address=/gw.wlan/192.168.4.1

 # Alias for this router


hostapd
    interface=wlan0
    ssid=NameOfNetwork
    hw_mode=g
    channel=7
    macaddr_acl=0
    auth_algs=1
    ignore_broadcast_ssid=0
    wpa=2
    wpa_passphrase=AardvarkBadgerHedgehog
    wpa_key_mgmt=WPA-PSK
    wpa_pairwise=TKIP
    rsn_pairwise=CCMP

net.ipv4.ip_forward=1 is enabled

1

1 Answer 1

1

So Apparently You need to set the IP of the PI after restarting the hotspot after connection to WIFI , Just run ifconfig wlan0 for me it was ifconfig wlan0 192.168.X.X And everything will work

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Commented May 1, 2020 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.