Appreciate any help. I am looking to download older version of Raspberry Pi Imager. The reason is I need to download ubuntu 16.04 arm64 for Pi 3B and Pi4B. The latest imager dooes not show thsese releases in the list when we open the tool. I downloaded ubuntu 16.04 arm64 for Pi 3 and Pi4 from ubuntu site and imaged to sd card and does not work. I think if i download using pi imager will work.

Thanks for any inputs.

  • 1
    Probable cause is the image size: raspberrypi.stackexchange.com/q/111236/5538
    – goldilocks
    Apr 25, 2020 at 15:00
  • 1
    Download the images separately and use balenaEtcher to flash them. NB: I haven't tried this particular combination, but Etcher hasn't failed me yet.
    – Bob Brown
    Apr 25, 2020 at 15:32
  • thanks for the reply, but already used Etcher, but did not boot my Pi3B and Pi4B..not sure..
    – user118802
    Apr 25, 2020 at 15:44
  • I just tried this also, but Pi3B does not boot ? dd if=ubuntu-16.04.4-server-arm64.iso of=/dev/sdb1 bs=100M
    – user118802
    Apr 25, 2020 at 15:52

2 Answers 2


To download previous versions of Raspberry Pi Imager (starting from v1.2), check out the Releases page on the rpi_imager GitHub site:


Click the "assets" tab to see the available downloads.


The wrong part is

dd if=ubuntu-16.04.4-server-arm64.iso of=/dev/sdb1 bs=100M

You are trying to flash a device image into a partition. You need to flash it to the block device itself, i.e. /dev/sdb.

The same issue is possible in Windows, but the terminology will change from one program to another. In some programs partitions are called disks.

  • thanks, with this I am getting error: dd if=ubuntu-16.04.4-server-arm64.iso of=/dev/sdb bs=100M dd: failed to open '/dev/sdb': Permission denied
    – user118802
    Apr 25, 2020 at 17:48
  • Run it as root. And make sure you've selected the right device, there will be no second warning before the device is overwritten. Apr 25, 2020 at 17:49
  • Thank you, i am able to flash now after running as root, but the Pi does not boot?? dd if=ubuntu-16.04.4-server-arm64.iso of=/dev/sdb bs=100M
    – user118802
    Apr 25, 2020 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.