0

Hi my goal is to step up my pi 4b with berryboot loading the OS onto a SSD where I can start running docker to become better familiar with it. Then use pi-hole and pivpn and whatever else might be good for my network. I am running into issues different issues.

Details: raspberry pi 4b 1.1 (dt) 32gb SD card came in canakit for everything -formated fat32 SSD - 2.5" SATA III 480gb - formated exFat(Not sure if correct but worked)

Very easily set up berryboot and SSD, I start running into problems when docker comes into play. Every time I install docker it is using the aufs storage driver. Docker does not like aufs apparently and wants overlay2 as it's storage driver.

I went into raspi-config to see if something was there about storage drivers. I found this overlay thing under "advanced". I enabled it with the ability to write to it not only read it because again I am not quite sure what I am doing but I assume I can just reformat any and try again if it fails.

I then tried to reboot and now the nnc1: timeout waiting for hardware interrrupt. I turned it off and tried turning back on with same error and it not actually booting at all.

I will be starting over from scratch now and would very much appreciate any help or just any info about what I am describing. Even if it is only about part of what my issue and won't solve the entire issue.

If anyone wants to know about the commands I used to install docker.

curl -sSL https://get.docker.com/ |sh

Sometimes I have to add --fix-missing because it asks me too despite the fact I wouldn't think anything was missing because I have fresh installs.

If anymore information is needed I will be quick to add any info needed since I am home all the time now with the Virus out and about. Stay safe everyone!

0

I found a new way to get docker running on the lastest raspbian OS with raspi 4b. Unfortunately I had to scrap berryboot because the kernel for berryboot isn't compatible with docker I believe so no SSD :(

  1. Download Debian Buster
  2. Enable SSH file in root of SD card if not running desktop
  3. curl -fsSL https://get.docker.com -o get-docker.sh
  4. sh get-docker.sh
  5. sudo usermod -aG docker $USER
  6. docker pull portainer/portainer
  7. docker run -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock --restart always --name portainer portainer/portainer -H unix:///var/run/docker.sock

Then just go to your browser type in your-IP--address:9000 and you should be at portainer to manage your docker containers. If you run into an issue with passwords there are a couple easy things to do to fix them online or ask.

I was able to get pihole up and running on a container and now am trying to get pivpn with wireguard but I am unsure if that is feasible yet for me being a noob and still struggling. Any tips would be much appreciated!

0

I had the same problem. I found this solution to work.

Summary:

  1. Flash a fresh Raspbian install to your SD card, which will be used to boot the system.
  2. Use fdisk to partition the SSD. Assuming the SSD is /dev/sda, run fdisk /dev/sda, d, n, enter for defaults, w, q.
  3. Format the partition: mkfs.ext4 /dev/sda1
  4. Mount the partition:
mkdir /media/newdrive
mount /dev/sda1 /media/newdrive
  1. Copy the OS: rsync -avc / /media/newdrive
  2. Edit /boot/cmdline.txt, modify root device.
nano /boot/cmdline.txt
root=/dev/sda1 rootfstype=ext4 rootwait
  1. Reboot

Now you have a normal Raspbian install, without the berryboot limitations. Docker works fine with the overlay2 storage driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.