I have followed the instructions on the following website (https://chainskills.com/2017/02/24/create-a-private-ethereum-blockchain-with-iot-devices-16/) to install geth Ethereum client on a Raspberry Pi 3B.

After I download the binaries, untar, move the geth folder into my /usr/local/bin and type geth I get the following error:

Command 'geth' is available in '/usr/local/bin/geth'
The command could not be located because '/usr/local/bin' is not included in the PATH environment variable.
geth: command not found

If I cd into the folder and try running it I get the same error. If I run it with sudo I get sudo: unable to execute /usr/local/bin/geth: No such file or directory.

The version I am installing is the following: geth-alltools-linux-arm7-1.9.13-cbc4ac26.tar.gz and I am using Ubuntu Server 20

  • 1
    That last one is telling "No such file or directory". what if you run file /usr/local/bin/geth ? – rob Apr 30 '20 at 14:24
  • Try /usr/local/bin/geth/geth. – user96931 Apr 30 '20 at 22:41
  • I tried that, but found via file geth that it is an executable and not a folder. See my answer below. – Alejandro May 1 '20 at 11:54

I found the solution. Two things:

  1. I had installed an Ubuntu ARM64 OS so the geth version had to be changed from ARM7 to ARM64.
  2. Run geth using sudo
  • 1
    Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo May 4 '20 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.