0

The problem: I am trying to create an AP on a Raspberry Pi 3B (want to later try on a Zero W, too) running buster. I also want to have Internet connectivity to the Pi using my Wi-Fi. I have studied several tutorials such as:

https://thepi.io/how-to-use-your-raspberry-pi-as-a-wireless-access-point/

and others and successfully implemented a solution using eth0. However, what I want is that instead of eth0 the Pi should use wlan1. To this end I looked up various ways of doing using dual Wi-Fi:

https://www.processthings.com/post/66023171876/how-to-connect-your-raspberry-pi-to-two-wi-fi https://www.raspberrypi.org/forums/viewtopic.php?t=49283

I even followed this: https://www.raspberrypi.org/forums/viewtopic.php?t=191453

but I am unable to achieve my objective. Here’s what my files look like

/etc/dhcpcd.conf

interface wlan0
static ip_address=192.168.1.11/24
denyinterfaces eth0
denyinterfaces wlan0

/etc/dnsmasq.conf

interface=wlan0
  dhcp-range=192.168.1.21,192.168.1.30,255.255.255.0,24h

/etc/hostapd/hostapd.conf

interface=wlan0
bridge=br0
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
ssid=Hello123
wpa_passphrase=asdasdasd

/etc/default/hostapd

DAEMON_CONF="/etc/hostapd/hostapd.conf"

/etc/network/interfaces

auto lo

iface lo inet loopback
#iface eth0 inet dhcp

auto wlan1
iface wlan1 inet dhcp
wpa-ssid Hello123
wpa-psk asdasdasd

I cannot connect to the net (cannot browse or ping) and ifconfig doesn’t show wlan1 at all.

So, what am I doing wrong? And is it even possible for wlan0 and wlan1 to coexist in this fashion? All the examples using hostapd only show eth0 bridges. In fact, I am OK even if the bridging doesn't happen - I just need the ability to connect to the Pi through AP mode and the Pi should be able to contact a website for data.

2

It is unclear what you really want:

I just need the ability to connect to the Pi through AP mode and the Pi should be able to contact a website for data

But you are talking about wlan1 that is usually provided by an additional USB/WiFi dongle. You do not need it for what you have written. With a Raspberry Pi 3B+ you can just use the built-in WiFi with interface wlan0 and its wired port with interface eth0. With wlan0 you create the access point and with a wired connection on eth0 you have the uplink to your internet router. How to configure it you can look at

Setting up a Raspberry Pi as an access point - the easy way.

You may use section "♦ Setting up an access point and with eth0, with NAT (recommended)". If you like to have bridge then look at section "♦ Setting up an access point with a bridge".

If you want to have a wireless uplink instead of the wired connection you can look at Access point as WiFi router/repeater, optional with bridge or if you want to use an additional USB/WiFi dongle then you can use an Access point as WiFi router/repeater with additional WiFi-dongle.

0

Try running the commands as follows:

rfkill list wlan
rfkill unblock wlan
echo "Check that wifi is unblocked."
rfkill list wlan

Just use the command

man rfkill

for an explanation.

Raspbian now uses rfkill to disable wifi if there is no valid country code in /etc/wpa-supplicant/wpa-supplicant.conf. This seems to be a relatively new addition which is why scripts that used to work no longer do.

Dazz

1
  • What does this do? Can you provide an expanation? – Chiwda May 5 '20 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.