Having previously got network boot working following this tutorial, I thought I'd try to combine it with the steps for using an USB SSD as rootfs.

This worked on Raspbian as follows:

  • Make a machine-specific boot folder tftpboot\<Serial#> on the server
  • Configure cmdline.txt root as the SSD's PARTUUID
  • Change /boot to mount from <server>:/tftpboot

However, when I tried the same with Ubuntu 20.04 arm64 server it fails to boot.

I can get Ubuntu 20.04 to start with a SD card as boot media, which outputs this on boot:

Net:   No ethernet found.
starting USB...
No working controllers found
## Info: input data size = 6 = 0x6
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr

But when I attempt it via network boot, instead of "switch to partitions #0, OK" I get:

Card did not respond to voltage select!
Card did not respond to voltage select!
starting USB...
No working controllers found
USB is stopped. Please issue 'usb start' first.
starting USB...
No working controllers found
No ethernet found.
missing environment variable: pxeuuid

And although this ends with a U-Boot prompt, USB isn't working at this stage so I can't do anything with it.

The NFS server shows that the client is fetching files during the network boot (otherwise, it would have nowhere to get U-Boot from).

Although the working 20.04 boot prompts "Hit any key to stop autoboot", keyboard doesn't work here either, so perhaps USB just doesn't work at this stage of this image's boot process.

Is there anything I can do to get more information on what's going wrong?

1 Answer 1


Im facing similar issue trying to netboot Ubuntu Server 20.04.

I eneded with connecting serial adapter to Pi - that gived me "keyboard".

Also compiled u-boot from source (to get ethernet) - source: https://github.com/apritzel/u-boot

Instructions: https://andrei.gherzan.ro/linux/uboot-on-rpi/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.