2

I know there is a ton of topics "My raspberry won't boot" but I need to create a new one, sorry :) I simply didn't find the solution to my problem anywhere.

My Raspberry 3 with OSMC suddenly stopped working a few days ago - no internet (ethernet port was also "dead") and TV just showed "no signal"., but on the other hand LEDs were blinking both (it's a good sign, right? :) ). So I tried second SD card with a fresh image of OSMC and Raspberry booted without any problem. So I assume there must be a problem with SD card but after connecting it to my laptop it was mounted without any issue and fsck found just a few errors. But even after fixing those errors raspberry still behaves the same way.

Of course, I can simply reinstall the OSMC and it will (probably) work fine but I'm too lazy to configure it again. So I'll be happy for any help or hint. Thanks

2

As you wrote you can read and repair the old SD Card attached to your laptop. So just take an image of it and flash it to the new SD Card you have verified that it is working.

If this doesn't help then you can try to debug why the RasPi does not boot correctly. You will find some steps at Can't boot from SD-card. Or - depending on the effort - you start again from scratch and swear to take a backup of it.

| improve this answer | |
  • Thanks for your reply. I tried to restore the image from the old SD card to the new one (which worked with fresh OSMC image) by this guide beebom.com/how-clone-raspberry-pi-sd-card-windows-linux-macos and the same situation like before - LEDs are blinking but that's all, everything else is dead. Any other idea? The image itself must be somehow corrupted, but how to check it? Fsck doesn't show anything, SD card is working normally on the laptop. – user1928543 May 9 at 10:40
  • @user1928543 I have updated the answer. – Ingo May 10 at 9:04
1

"I'm too lazy to configure it again. So I'll be happy for any help or hint."

Make a backup.

Experienced users don't usually attempt recovery (it is too much work, and unreliable) - we just restore from a backup if the image becomes corrupt.

| improve this answer | |
  • Thanks Milliways, but what file/folder should I backup and upload back to the newly imaged SD card? So I will have a "fresh" installation of OSMC but with old settings... – user1928543 May 10 at 6:00
1

Sometimes these errors can not be fixed. These types of problems most of times happens because of crashed applications or scripts. I have seen many problems like this. Even if I use it with great care, some problems always come back. I suggest you take a backup and get inside your rootfs with another linux PC or use some software in windows to get there. Recover everything and re install the image.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.