1

I've been flashing and re-flashing my SD card to no avail. The annoying things is that it was able to connect to the WiFi network on first start-up, and then it decided never to connect to the internet again.

My steps to reproduce are these:

  1. Flash raspbian image using sudo dd bs=1m if=2020-02-13-raspbian-buster.img of=/dev/rdisk2 conv=sync. I'm on a Mac.
  2. sudo touch /Volumes/boot/ssh
  3. sudo cp wpa_supplicant.conf /Volumes/boot/
  4. Eject the SD card, insert it into the pi, and power it on.
  5. Nothing. The first time I used the pi, it worked perfectly. Then I restarted it and it has not worked since. It doesn't connect on WiFi or via Ethernet. My router doesn't show the device as connected.

I'm on a headless setup so I can't inspect what's going on internally. I've ordered a mini-HDMI adapter, but it will take some time before it arrives.

The red power LED is on, and the green one adjacent is flashing periodically. I understood this to be an indication that it has fully booted and is running.

I've noticed that the first time I flashed the image it took a lot longer than subsequent runs. I'm guessing that this is because many sectors have not been altered and aren't overwritten. I'm worried that it's not overwriting sectors that should be overwritten; for instance something that the pi is using on startup to decide not to connect to the network. I'm speculating, but it might be that I didn't correctly configure SSH to run on non-initial launches before that first restart, and there's a file somewhere in the main partition that the pi interprets as indicating second launch.

The troubleshooting guide doesn't have any section on this, so I'm not sure how to troubleshoot this. I'm suspecting a DHCP or DNS issue, but I don't know how to configure it differently by tweaking the boot sector. Nothing in my router logs (Verizon Fios, G3100) indicates that the device is being rejected.

  • how long are you waiting after the first boot after flashing, since this first boot is when the Pi expands the second partition, it could take a while. Also, are you sure /Volumes/boot is the sd card? (I don't know Mac's so ...) – Jaromanda X May 9 at 6:39
  • Without having access to the RasPi there is not much that you can do. You may also consider to use an USB to serial adapter. – Ingo May 9 at 10:54
  • Thanks for the responses. It seems to have been an issue with the specific power supply I was using. After trying with SSH over USB, it was also connecting to WiFi, and then changing the power supply caused it to continue working. – EnvisionRed May 9 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.