2

Pi version: 1.3, camera revision: 1.3. Correctly connected.

OS: Raspbian lite buster. Freshly installed. The firmware is updated to the latest one with rpi-update and the system too with apt update && apt full-upgrade.

The camera interface is enabled via raspi-config.

/boot/config.txt contents:

start_x=1
gpu_mem=128
start_file=start_x.elf
fixup_file=fixup_x.dat

Rebooted but still having:

pi@raspberrypi:~ $ vcgencmd get_camera
supported=0 detected=0

Any ideas?

7
  • 1
    raspistill or raspivid also doesn't work ?
    – Ephemeral
    May 9 '20 at 8:03
  • 1
    mmal: Camera is not enabled in this build. Try running "sudo raspi-config" and ensure that "camera" has been enabled
    – fey
    May 9 '20 at 8:06
  • 1
    After reboot your camera is always enable in raspi-config ? Also check if any another programm not already use the camera.
    – Ephemeral
    May 9 '20 at 8:11
  • 1
    Sure. It changes /boot/config.txt properly.
    – fey
    May 9 '20 at 8:20
  • 1
    Let us continue this discussion in chat.
    – Ephemeral
    May 9 '20 at 8:25
1

Eventually it worked after I reinstalled the OS changing it to the regular GUI version from the Lite one. I didn't run rpi-update again since the new firmware had been already installed.

Not sure whether it's because of some issue with the Lite version either just the system needs to be reinstalled after the firmware update but anyway now vcgencmd get_camera shows supported=1 detected=1 and raspistill works.

Thanks to Ephemeral for the help.

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    May 12 '20 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.