1

I'm using the Raspberry Pi 4B with 2GB of RAM. I have no problems with WIFI connection, though. But I can't make connection using nm-applet (and nm-connection-editor). On nm-applet it shows "device not ready" under "Wi-Fi Networks". Anyway, I can connect to WIFI using the built-in (LXDE or PIXEL, I believe) WIFI manager.

Summarising, I'd like to have possibility to connect to WIFI on wlan0 (Raspberry Pi 4B built-in WIFI interface) using NetworkManager.

  • Have you installed Network Manager? – Milliways May 11 at 21:37
  • @Milliways Yes, I installed "network-manager" and "network-manager-gnome" – Cimlah May 11 at 21:40
  • What operating system do you use? Raspbian Buster? – Ingo May 13 at 10:22
0

If you want to use Network Manager you need to disable the default Raspbian dhcpcd network management tool. The 2 systems are incompatible.

There is no advantage in Network Manager, and it does not really suit the Pi modus operandi - in particular swapping SD Cards between Pi won't work - each Pi needs to be configured individually (although I cannot be sure what Network Manager would do on Raspbian).

You will probably have to enable predictable network interface names

| improve this answer | |
  • Thank you. It worked – Cimlah May 12 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.