0

I recently bought a new RPi 4 and tried to install the module I ran on the old RPi 3B (which ran successfully). Now, when trying to install the same module on the RPi 4 I get 2 warnings when compiling the kernel module - WARNING: "__sanitizer_cov_trace_const_cmp4" [/home/pi/AMAT/ens_adc_3/ens_adc_3.ko] undefined! WARNING: "__sanitizer_cov_trace_pc" [/home/pi/AMAT/ens_adc_3/ens_adc_3.ko] undefined!

When trying to install the module, I get - insmod: ERROR: could not insert module ens_adc_3.ko: Unknown symbol in module

I installed the most updated kernel headers and I couldn't find any solutions when I Googled. Any suggestions?

0

Problem solved - I formatted the SD card, installed Rasbpian, and all the relevant packages again. in one of the packages I was asked if I want code coverage for fuzzing installed (KCOV), and this time I replied no. The problem no longer occurred when compiling the kernel module.

| improve this answer | |
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo May 17 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.