2

I recently got the Raspberry Pi 4 for a university project. I installed Ubuntu Server 20.04 on it. Now I am trying to enable a second uart port because for the project I need to connect multiple sensors via uart. But after I set dtoverlay=uart4 in usercfg.txt, the system got stuck on the rainbow splash screen. I disabled Bluetooth, Wi-Fi, spi, and i2c, but it didn't help.

Do you guys have any suggestions what I can try?

6
  • any reason you use uart4 rather than, say uart1? May 14, 2020 at 0:58
  • uart0 and uart1 use the same pins. So i can choose only from uart2 to uart5. But unfortuanally they wont work ... May 14, 2020 at 1:45
  • Ubuntu Server is limited to what Canonical choose to include - many of Raspbian's features are omitted. You might be able to copy the Device Tree overlay and kernel modules from Raspbian.
    – Milliways
    May 14, 2020 at 1:56
  • yeah in /boot/firmware/overlays there are some like disable-bt and disable-wifi. But there are also uart0 - 5. So why should ubuntu ship them when they dont work. May 14, 2020 at 9:04
  • 1
    ok i downgraded to ubuntu 19.10.1 and it works as intended. why not in 20.04? May 15, 2020 at 16:11

1 Answer 1

1

I have recently tested it again. It works fine now. :)

2
  • To improve your answer, can you clarify what you did to resolve this? Is this working for you on 20.04? Did you make any changes to get it working? Apr 26, 2021 at 18:01
  • I just updated Ubuntu and it now works exactly as it did in 19.10.1. Apr 29, 2021 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.