0

I installed the latest Raspbian on an SD card using Imager. The first boot: everything OK. Updates, installs, rebooting: worked perfectly fine.

However, after shutdown, the screen is blank. After connecting the power cable red light is on, green light goes on, then blinking, then off -- I am guessing it is loading from the SD card. But the screen is dead, it doesn't even show that anything is connected.

I do use HDMI-VGA adapter, so would've loved to test on pure HDMI connection but currently cannot do it (COVID-19, lockdown). Power supply: 2.5 A. There were neither rainbow nor red squares prior to shutdown.

The same problem happened when I installed Raspbian light, but I thought maybe I did something wrong with configs, so tried with the full Raspbian.

It seems the same problem was reported here, but with no answer.

  • How big is the SD card? I've seen long boot times on larger cards as the Pi expanded the partitions. Took a few minutes from my memory. – Andyroo May 14 at 17:30
  • @Andyroo 32 GB. At some point green light stop flashing - I assume it finished or stopped loading. Also, on reboot and on the first run it gave rainbow splash screen before showing loading screen. And reboot after the resize worked fine (and fast). The problem only occurs after shutdown. – mobiuseng May 14 at 20:42
  • Is it after every shutdown then? Be interesting to load Stretch and see if that does the same. – Andyroo May 14 at 21:11
  • how about you enable ssh, then if it is booting but without display (did you even try to ping the pi?), you can do some investigation of logs, dmesg etc – Jaromanda X May 15 at 1:53
  • Plot thickens... I installed MATE instead of Raspbian since it was a solution for someone in the past. It worked for a while. I even did shutdown and start again: was fine. Things seem to brake after sudo apt upgrade. – mobiuseng May 21 at 10:20
0

Disclaimer: I don't know what caused the problem. It seems that a kernel update might be a culprit. But I am not certain.

Two changes that allowed it to work (this on MATE now): in user config file (which is conveniently on FAT32 partition, so can be accessed from anything) I forced the use of HDMI with hdmi_force_hotplug=1 -- I thought it might have been a problem since I am using HDMI-VGA adapter for my old monitor. This enabled video output. The resolution was off. So, I had to play with hdmi_mode to get it right (mode 36 was the right one for my screen).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.