0
1. Summarizing the problem

No display (https://www.amazon.de/gp/product/B07XPM2ZS3) after LVM tutorial anymore.

2. Providing details and any research

After using this Tutorial (Easy backups and snapshots of a running system with LVM) from Ingo (https://raspberrypi.stackexchange.com/users/79866/ingo) everything was/is fine with my Raspberry (Raspberry Pi 4 Modell B; 4 GB, ARM-Cortex-A72 4 x, 1,50 GHz, 4 GB RAM, WLAN-ac, Bluetooth 5, LAN, 4 x USB, 2 x Micro-HDMI ) with a Raspian Buster, Pi-hole, Wireguard installation beside not having a Bruphny 4.0 display anymore (https://www.amazon.de/gp/product/B07XPM2ZS3). Still access to the cli. The display is just turning on and off in intervals.

3.Describing what I’ve tried

Tried to redo the whole LVM installation but came out with the same result. The display is recognized by the Raspian Buster default Installation.

0

It should not make a difference if you run the root filesystem from a primary partition or from a logical volume. The operating system only sees the ext4 filesystem, no matter where it is located. Because you restore a complete backup of the SD Card to the logical volume there should also not be a difference.

The only thing I see is, that the display driver has to load at an early stage that is now done with an initramfs, needed to load the LVM driver to access the logical volumes before accessing the root filesystem. So I would check if the display driver is needed in the initramfs and then available there. You can check the contents of the initramfs with:

rpi ~$ lsinitramfs -l /boot/initrd.img-4.19.97-v7l+

I have also optimized the size of the initramfs by including only listed modules. This it set in /etc/initramfs-tools/initramfs.conf with option MODULES=list. You can try to add most filesystem and all harddrive drivers with:

MODULES=most

But this will increase the size of the initramfs a lot and you will need enough space on the fat32 boot partition. Play with the other options given for MODULES= together with loading modules in /etc/modules or /etc/modules-load.d/. But be sure to always include the lvm driver, otherwise you are lost with an unbootable system. Don't worry, there is a way to repair it. But better check with lsinitramfs before booting.

Update:
@Lawful confirmed in a comment that just setting MOUDULES=most as described above, was the solution. Obviously this also includes the display driver into the initramfs so it can start early.

| improve this answer | |
  • Hi Ingo, I changed the MODULES section of /etc/initramfs-tools/initramfs.conf to =most and it worked instantly. Thank you! If you would like I could open another question to let you explain "How I can identify and set the needed module which was missing" to make it work. What do you think about my proposal? Please let me know. – Lawful May 16 at 9:35
  • @Lawful If you like to create a new question with answer then it is a good idea. I would prefer to update this answer with the information from your comment and have a link to it on the original tutorial. So we have it all together in context. Tell me what to do. – Ingo May 16 at 9:48
  • I totally agree with you. Lets update this answer with the information to have it all together. – Lawful May 16 at 14:41
  • The follow-up we may agreed on: raspberrypi.stackexchange.com/questions/112515/… – Lawful May 17 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.