0

Traceback|SyntaxError

I have enclosed the screenshot of the error above.

Looking for solution to SimpleCV traceback/syntax error problem:

I have already tried installing SimpleCV with a fresh image of Raspbian Buster.

Also, tried re-installing SimpleCV every time, with a newer python3 version: 3.5, 3.6, 3.7, and 3.8.

But, the error still persists.

I am using RPi 3B running Raspbian Buster release.

Using update-alternatives I changed python and python3 versions >> 3.5.9

Similarly, used the same method to change pip and pip3 version >> 20.1

Also, edited /usr/bin/lsb_release from #! /usr/bin/python2.7 to #! /usr/bin/python3.5

Then, installed SimpleCV following these lines of code:

$ sudo apt-get install ipython python-opencv python-scipy python-numpy python-setuptools python-pip
$ sudo pip install svgwrite
$ https://github.com/sightmachine/SimpleCV/zipball/master --no-cache-dir
$ pip install 'IPython==4' --force-reinstall
1
  • 2
    Please don't post pictures of text. Instead paste the text direct into the question.
    – Ingo
    May 16, 2020 at 19:39

2 Answers 2

1

Looking at the error message, did you try to edit "base. py" and correct the syntax error by adding parantheses to the statement? ... print('unit test')

1

The print statement requires parentheses since Python 3. It looks like you are trying to run Python 2 code with Python 3. Try running it with Python 2 or see if you can find an updated version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.