I am able to configure WiFi with Jessie on Pi Zero issuing the following instructions from the command line:-

sudo su
wpa_passphrase "SSID" "PASSWORD" >> /etc/wpa_supplicant/wpa_supplicant.conf
wpa_cli reconfigure

This doesn't work for Buster however so I am wondering what has changed and how I can get wifi working on Buster?


  • You need to use current Raspbian settings. See How to set up networking/WiFi
    – Milliways
    May 17 '20 at 0:21
  • Thanks. I tried but it fails at the first hurdle. Tried to set localisation and get 'Could not communicate with wpa_supplicant'
    – Nick C
    May 17 '20 at 6:11

I finally got this working.

Started from scratch with fresh install of Buster. Configured the wpa_supplicant.conf by following directions in this post - https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=274194&p=1662955#p1662955 and installed the relevant WiFi driver from here - http://downloads.fars-robotics.net/wifi-drivers/8188eu-drivers/

Thanks all for help!

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    May 24 '20 at 8:32
  • Ah yes thanks for reminding!
    – Nick C
    May 24 '20 at 18:06

The file has to have a few specific entries now. The minimal file contents I have found are:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

        ssid="Something here"

Can you edit your question and put your file here (redact the SSID and password) via a copy and paste as Buster is picky over quotes and characters used.

My guess - the country ID is missing...

  • Thanks Andyroo. I created a wpa_supplicant.conf file with exactly what you have above (my network and password details in between the course). I placed this in the boot folder and checked the contents of /etc/wpa_supplicant/wpa_supplicant.conf after boot. They were the same. I still have now connectivity however. The quotes I presume should be left in there right?
    – Nick C
    May 16 '20 at 17:30
  • Quotes should be around the SSID and password in this format - I'm on an iPad at the moment and quotes are a pain (even with auto-correct off) but use the shift-2 character on a Windows UK keyboard. There is an odd quirk where the number of characters and the character set are different between different versions of Linux and access points but I've never got a clear document on what the limits are so I stick to long strings and a few extra chars mainly.
    – user115418
    May 16 '20 at 17:47
  • Thanks. I'm pretty sure the quotes are correct but I doubled checked using shift-2 (Windows keyboard). Still no joy though. As a matter of interest I upgraded Jessie to Stretch earlier on another card and the WiFi is fine with that where before I had the same problem with Stretch as with Buster. I suppose this might be a workaround therefore but I am keen to find out what is the problem with regards a fresh install.
    – Nick C
    May 16 '20 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.