0

I'm stuck at the installation process for openhabian , I realized I couldn't get package python3-bluez to install. script ran :

    needed_packages() {
  # Install apt-transport-https - update packages through https repository
  # Install bc + sysstat - needed for FireMotD
  # Install avahi-daemon - hostname based discovery on local networks
  # Install python/python3-pip - for python packages
  echo -n "$(timestamp) [openHABian] Installing additional needed packages... "
  if cond_redirect apt-get -y install apt-transport-https bc sysstat avahi-daemon python3 python3-pip avahi-autoipd fontconfig; then echo "OK"; else echo "FAILED"; exit 1; fi

  if is_pithree || is_pithreeplus || is_pizerow; then
    echo -n "$(timestamp) [openHABian] Installing additional bluetooth packages... "
    if cond_redirect apt-get -y install bluez python3-bluez python3-dev libbluetooth-dev raspberrypi-sys-mods pi-bluetooth; then echo "OK"; else echo "FAILED"; exit 1; fi
  fi
}

Couldn't really find what's wrong, the rest of the packages : bluez python3-dev libbluetooth-dev raspberrypi-sys-mods pi-bluetooth were installed successfully. When I ran python -V it shows 2.7.13. Any help would be appreciated!

2
  • You may have better luck posting your question as an issue on the openhabian GitHub site. – Seamus May 17 '20 at 4:31
  • python3-bluez is available i – Dirk May 17 '20 at 7:49
1

The package you've asked about - python3-bluez is available in the current package repository (buster). This may be verified as follows:

$ apt-cache search python3-bluez
python3-bluez - Python 3 wrappers around BlueZ for rapid bluetooth development

If it can't be found in openhabian, then the problem is with openhabian, and you will have to submit the issue to them for resolution.

Wrt your comment/observation re python -V; I get something different on my system (Raspbian Buster):

$ python -V
Python 2.7.16

In Raspbian, Python ver 3 is known as python3 rather than python:

$ python3 -V
Python 3.7.3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.