1

I've used the Raspberry Pi Imager utility to download and install Ubuntu Server 20.04 x64 on an SD card, and added hdmi_force_hotplug=1 to usercfg.txt before booting up.

This worked just fine for Raspbian OS (except the file modified in that case was config.txt) and yet, I don't get a console or any output whatsoever after the four-pixel color test appears and disappears.

The monitor does not go to sleep - it maintains a blank screen and an active display. I can still shut it down with Alt+Fn+SysRq+O but nothing else produces any output, only the low-level BIOS shortcuts like SysRq and CTRL+ALT+DEL trigger any response.

I apologise if this question has been answered, I was not able to find it. Could anyone suppose what mistake I am making?

Troubleshooting attempted

  • I've tried adding a static IP to the netconfig (optional: true) and SSH is 'not able to find a route.' Notably I did not add an ssh file to the boot partition at the time.
  • I've tried more specific HDMI settings, forcing it to my native resolution with reduced blanking - no change.
  • I've deleted the Imager's cache and re-downloaded / re-verified the SD card, with the same results.

Thanks again.

1

I thought it would be funnier to answer my question than delete it - switching the HDMI port helps!

1
  • 1
    so it's a raspberry pi 4? – Jaromanda X May 19 '20 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.