2

I received my 3rd Pi4 4GB kit from Velros and all I did is move the known working sdcard from my working Pi#2 board into this new one.

However, after it boots I see 4 raspberries in the upper left corner, sometimes the desktop appears briefly but then I get a black screen and no-signal on the TV it is attached to.

Do I have to go thru an install eg. via an sdcard with NOOBS on it, or is what I did sufficient to claim this board is faulty?

Searching about what might be stored on a Pi board like BIOS, firmware, ... and according to a post here relating to firmware upgrading, I conclude that all the "personality" of a Pi board is included in a working sdcard, which is great. Since the firmware is actually loaded from a partition of the SDcard the behavior should be the same on any fresh board.

Please correct me if my understanding is wrong. Thank you.

I did try another working sdcard and got the same fail results.

enter image description here

Do I still need rpi-update if I am using the latest version of Raspbian?

4

"Do I still need rpi-update if I am using the latest version of Raspbian?"

I don't know how often people need to be told, or why they ignore the warning if they do run it!

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware."

sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

If you have used an old NOOBS (i.e. - a pre-Buster version) you have no hope - just do a fresh Raspbian installation.

| improve this answer | |
  • The working#1 SDCard is from a manual flashing on my Windows7 PC using Pi Imager v1.2 like 3 weeks ago. the working#2 SDCard is from install with NOOBS that came on the SDCard from Velros. Both working SDCards are failing on this fresh board Pi#3 board. Do I still have to do install on the board? I never performed any rpi-update to this date. – Meryan May 25 at 8:13
  • Keep in mind that on this Pi#3 new board I can't get to any screen, there is no video signal to the TV. So I presume it's another dead fail board. – Meryan May 25 at 8:15
1

To expand on what Milliways has written.

On a brand new RPi4B you should get a copy of plain Raspbian and boot that. As soon as it's booted run sudo apt update; sudo apt dist-upgrade -y; reboot as soon a it has rebooted run sudo rpi-eeprom-update to get the latest stable version of the bootcode.

Don't install the beta version of the EEPROM update, it's still being tested. Do not run sudo rpi-update unless an expert tells you to run it (as it will get an experimental 5.4.42 kernel that is still not fully debugged).

Once you've done that process, then switch SDCard to boot whatever other operating system you'd like to run. Keep the Raspbian card as a bootable rescue system. In a couple of months time boot it again, run sudo apt update; sudo apt dist-upgrade; sudo rpi-eeprom-update to get the latest firmware.

Details of the EEPROM updating process are at: https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md

If you want to use a NOOBS-like multiboot manager (on a 32GB SDCard or larger) take a look at PINN https://github.com/procount/pinn (which is an enhanced version of NOOBS and includes a self-updating process).

| improve this answer | |
  • If by "plain Raspbian" you mean put Raspbian on an sdcard with the Pi Imager than that's what one of my sdcard has on it, the other working sdcard has minimal autostart to launch the browser and some preferences colors to the desktop. However with both I get no video signal so how can I run any of the sudo commands you are suggesting? – Meryan May 25 at 10:11
  • @Meryan that's what you need. The thing you need to do it boot it, update/upgrade it then run the rpi-eeprom-update to get the latest stable firmware. – Dougie May 25 at 10:25
  • I am sorry but I don't seem to be clear enough, there is no way for me to run any commands. Last thing I tried is go thru BOOT the NOOBS SDCard from the Velros kit and install Raspbian but as soon as it got to setting the new OS asking about the locacation and language, it started flashing the screen, never got to asking about the user password. It's ANOTHER GARBAGE board very similar the 1st one I got. I am not going to waste hours again trying to fix something that should have worked out of the box. This one is going back. – Meryan May 25 at 21:29
  • The board did show up as 192.168.1.173 on my LAN/router but it fails trying to access it with putty. So that approach did not work either. – Meryan May 25 at 21:30
  • SSH is NOT activated by default. Pull the SDCard, stick it in your windows machine and create a file d:\ssh.txt on it (it doesn't matter what that file contains). – Dougie May 25 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.