0

I have a static IP setup for the raspberry pi and have no problem connecting via ssh while on the local network. I have the OpenSSH server running on the raspberry pi(pi4 model B running rasbian) and have established that it is listening on the proper port using netstat -an | grep "LISTEN " it outputs this(I changed sshd_config file to listen on port 5000 in case my ISP was blocking 22)

tcp 0 0 0.0.0.0:5000 0.0.0.0:* LISTEN

I've forwarded this port to my raspberry pi's static IP on my routers config page, however when I use canyouseeme.org to test if the port has been forwarded correctly I receive a connection timeout error. (My router is a TP-Link AC 750 4G LTE router).

Has anyone faced any similar issues or have any further tips for troubleshooting this issue?

0

First check if you get public IP from you ISP because Most 4G services don't provide public IP to is customer. They assign Private or LAN IP which are not accessible form outside network.

| improve this answer | |
  • Make sure the Pi is NOT the DMZ address, check both interfaces have the virtual server rule set up. Make sure the rules are enabled. Check the ports are correct on the rules. Check nothing else if using the port. Consider setting up a VPN on the router (a much better option). If you have a desktop on the Pi try VNC with the free account - this bypasses any port forwarding needs. – Andyroo May 25 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.