0

I'm trying to connect my Raspberry Pi 4B to a HANNspree ht161hnb touch monitor. It's a first time use with a sd cart with NOOBS(I'm new to Raspberry Pi) It's booting up (I see a "For recovery mode press shift" screen) then immediately it goes to "No Signal". I tried both hdmi ports. I am powering the monitor with the original 12v adapter. I connected an USB cable back to the Pi. https://www.hannspree.eu/product/ht-161-hnb/ What can be the problem?

  • Welcome. Any reason you are using NOOBS? I would jump straight into Raspbian to save issues. You could try the other hdmi port on the Pi. How are you powering the monitor? Does it have a USB connection back to the Pi? Do you have a link to the manual if no one has one here? You can edit your question to put these details in rather than using comments. – Andyroo May 26 at 22:03
  • I’m now able to install Rasbian OS on my sd card while connected to my Hannspree. I can follow it on the screen, but after installation it returns to the same; No signal??! – Guillaumeprints London May 29 at 12:23
  • Possibly it's the resolution or data coming back from the monitor baffling the Pi. I would try adding hdmi_ignore_cec=1 to /bot/config.txt and see if that helps. If not it's a case of going through raspberrypi.org/documentation/configuration/config-txt/video.md to set the monitor spec in config.txt – Andyroo May 29 at 17:58
  • I added hdmi_ignore_cec=1 to config.txt, but this is not the solution. I'm thinking to connect the Pi to my working (not touch-test) monitor. – Guillaumeprints London May 31 at 19:25
0

I have had the same problem with the same monitor and i use a raspberry pi 4, with my configuration works. This is my config.txt file:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1
hdmi_ignore_edid=0xa5000080

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=0

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=86

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

disable_splash=1
| improve this answer | |
New contributor
Alfredo is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    And what is different from the default settings of /boot/config.txt? Can you please explain a bit more? – Ingo 2 days ago
  • I have tried with safe_mode unabled and the monitor work but at limited resolution. – Alfredo 2 hours ago
  • I have tried with safe_mode enabled and the monitor work but at limited resolution. Reading the official guide raspberrypi.org/documentation/configuration/config-txt/video.md i have found the correct configuration using only some parameters enabled by safe_mode. – Alfredo 2 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.