0

I am using Magic Mirror together with my Raspberry Pi 3B+ (Buster) and an old laptop monitor. The website is displayed using kiosk mode with chromium. When my RPi normally starts, the monitor is turned off. That's why I've added hdmi_force_hotplug=1 to /boot/config.txt. But this doesn't work, somehow the hdmi output is off and the monitor says no signal detected. I've also set several settings to match my monitor settings:

/boot/config.txt

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=800

# use edid_file in boot folder
#hdmi_edid_file=1

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=28

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=9

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
# Next line commented out, cuz dtoverlay=vc4-kms-v3d is now in use
#dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d
# Magic Mirror added
dtoverlay=vc4-kms-v3d
avoid_warnings=1

But this is not working, if I turn the monitor on after boot, it says no signal detected.

I even tried a workaround by turning it after boot on with the command:

pi@himbipi:~ $ sudo /opt/vc/bin/tvservice -p
Powering on HDMI with preferred settings
[E] Failed to power on HDMI with preferred settings

But without success. It's strange, that the poweroff doesn't show any error and the monitor is staying on though:

pi@himbipi:~ $ sudo /opt/vc/bin/tvservice -o
Powering off HDMI

Maybe the settings in /etc/xdg/lxsession/LXDE-pi/autostart are influencing the behaviour?

pi@himbipi:/boot $ cat /etc/xdg/lxsession/LXDE-pi/autostart
@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
# Bildschirmschoner deaktivieren
#@xscreensaver -no-splash
@xset s noblank
@xset s off
@xset -dpms
# Bildschirm drehen
@xrandr --output HDMI-1 --rotate right
# Mauszeiger ausblenden
@unclutter -display :0 -idle 3 -root -noevents
# lädt Chromium im Vollbild bei einem Neustart
@chromium-browser --no-default-browser-check --check-for-update-interval=604800 --disable-pinch --incognito --kiosk http://localhost:80

At this point I don't have a clue, can anyone help me please? :)

Thank you very much

1

I suppose this is because your screen does not support the mode you're trying to set (hdmi_group=2, hdmi_mode=28 seems to be 288p with pixel quadrupling).

Start the Pi with the screen switched on, note the mode it is set to (using tvservice or otherwise), and set that mode in your config.txt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.