1

How do I get the Raspberry Pi Menu item back after upgrading to Raspberry Pi OS?

After the upgrade I had a "blank" Menu button which merged into the Panel.

1
  • same problem here.
    – Botspot
    May 30 '20 at 15:45
0

There is a rather confusing answer at https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=275473&p=1669223#p1669223

I wrote the following to restore the menu

#!/bin/bash
cp /usr/share/icons/HighContrast/16x16/places/start-here.png /usr/share/icons/hicolor/16x16/apps/start-here.png
cp /usr/share/icons/HighContrast/22x22/places/start-here.png /usr/share/icons/hicolor/22x22/apps/start-here.png
cp /usr/share/icons/HighContrast/24x24/places/start-here.png /usr/share/icons/hicolor/24x24/apps/start-here.png
cp /usr/share/icons/HighContrast/32x32/places/start-here.png /usr/share/icons/hicolor/32x32/apps/start-here.png
cp /usr/share/icons/HighContrast/48x48/places/start-here.png /usr/share/icons/hicolor/48x48/apps/start-here.png
cd /usr/share/icons/hicolor
sudo gtk-update-icon-cache

Then right-click on the blank icon, select "Menu Settings" and enter "start-here" into the icon box.

NOTE this may be a user induced problem. During upgrade you would have seen the following prompt:-

The desktop has been updated. To apply the updates, please reboot your Pi, and then select one of the options on the Defaults page in Appearance Settings.

I you don't touch the Appearance Settings/Defaults you may not have a problem, although the upgrade changes a number of customised Appearance Settings, requiring corrections.

0

Thanks for posting!

I have had a similar problem:

Working on Raspberry Pi OS (32bit) on small Bluetooth keyboard. Clearly I have hit some wrong keys, as a blank panel appears!

Reading the link in your post gave me the solution to this problem!

Here are my instructions: [] Right-click on the blank panel, for a menu. [] On the menu that appears, select Add / Remove Panel Items. [] On the Panel Preferences window that appears select the Panel Applets tab. [] On that same Panel Preferences window select Add (on the right-side). [] From the menu that appears choose Menu. [] The word Menu should now appear in the list of added plugins. [] Select Menu (so it is highlighted). [] On that same Panel Preferences window select Preferences (on the right-side). (A menu appears - which is also shown in your linked instructions). [] Delete the text in the Icon field (box on right of Icon word). [] Type in that same box (field) the letters rpi. [] Type the number 4 in the Padding field (box). [] Click [OK].

Hope it works for you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.